diff mbox series

[meta-networking] spice-gtk: Use libucontext for coroutines on musl

Message ID 20221226225742.1745493-1-raj.khem@gmail.com
State New
Headers show
Series [meta-networking] spice-gtk: Use libucontext for coroutines on musl | expand

Commit Message

Khem Raj Dec. 26, 2022, 10:57 p.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
index d654a36f48..44b42a3313 100644
--- a/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
+++ b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
@@ -38,6 +38,7 @@  DEPENDS = " \
 	usbutils \
 	zlib \
 "
+DEPENDS:append:libc-musl = " libucontext"
 
 RDEPENDS:${PN} = "python3-pyparsing python3-six"
 
@@ -46,5 +47,7 @@  inherit meson pkgconfig vala gobject-introspection features_check
 REQUIRED_DISTRO_FEATURES = "opengl"
 
 EXTRA_OEMESON = "-Dpie=true -Dvapi=enabled -Dintrospection=enabled"
+EXTRA_OEMESON:append:libc-musl = " -Dcoroutine=libucontext"
+
 
 FILES:${PN} += "${datadir}"