diff mbox series

[meta-python] python3-alembic: upgrade 1.8.1 -> 1.9.0

Message ID 1671538467-7143-5-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-alembic: upgrade 1.8.1 -> 1.9.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 20, 2022, 12:14 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
feature
--------
 [feature] [commands] Added new Alembic command alembic check. This performs the widely
 requested feature of running an "autogenerate" comparison between the
 current database and the MetaData that's currently set up for
 autogenerate, returning an error code if the two do not match, based on
 current autogenerate settings. Pull request courtesy Nathan Louie.

bug
-------
 [bug] [tests] Fixed issue in tox.ini file where changes in the tox 4.0 series to the
 format of "passenv" caused tox to not function correctly, in particular
 raising an error as of tox 4.0.6.

 [bug] [typing] Fixed typing issue where revision.process_revision_directives
 was not fully typed; additionally ensured all Callable and Dict
 arguments to EnvironmentContext.configure() include parameters in
 the typing declaration.

 Additionally updated the codebase for Mypy 0.990 compliance.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-alembic_1.8.1.bb => python3-alembic_1.9.0.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-alembic_1.8.1.bb => python3-alembic_1.9.0.bb} (81%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.8.1.bb b/meta-python/recipes-devtools/python/python3-alembic_1.9.0.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-alembic_1.8.1.bb
rename to meta-python/recipes-devtools/python/python3-alembic_1.9.0.bb
index 3e3115883..071c60705 100644
--- a/meta-python/recipes-devtools/python/python3-alembic_1.8.1.bb
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.9.0.bb
@@ -4,7 +4,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=f5a8522010db1a393833988dbe2c7f0b"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "cd0b5e45b14b706426b833f06369b9a6d5ee03f826ec3238723ce8caaf6e5ffa"
+SRC_URI[sha256sum] = "6af6792fe699730b27480382701b16028ebbaac6bc5cd4f06daf5fa3e4690364"
 
 PYPI_PACKAGE = "alembic"