[bitbake-devel] Bump minimum python version to 3.5

Submitted by Joshua Watt on Dec. 6, 2019, 6:12 p.m. | Patch ID: 167741

Details

Message ID 20191206181256.1392097-1-JPEWhacker@gmail.com
State New
Headers show

Commit Message

Joshua Watt Dec. 6, 2019, 6:12 p.m.
The local hash equivalence server used by bitbake requires python 3.5,
so bump up the minimum required version.

[YOCTO #13678]

Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
---
 bitbake/lib/bb/__init__.py | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch hide | download patch | download mbox

diff --git a/bitbake/lib/bb/__init__.py b/bitbake/lib/bb/__init__.py
index c144311be4c..b9d8bfa7694 100644
--- a/bitbake/lib/bb/__init__.py
+++ b/bitbake/lib/bb/__init__.py
@@ -12,8 +12,8 @@ 
 __version__ = "1.44.0"
 
 import sys
-if sys.version_info < (3, 4, 0):
-    raise RuntimeError("Sorry, python 3.4.0 or later is required for this version of bitbake")
+if sys.version_info < (3, 5, 0):
+    raise RuntimeError("Sorry, python 3.5.0 or later is required for this version of bitbake")
 
 
 class BBHandledException(Exception):