diff mbox series

[meta-ti,dunfell,2/2] optee-os: add back allow-setting-sysroot-for-libgcc-lookup.patch

Message ID 20221213183818.206660-2-jose.quaresma@foundries.io
State Rejected
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,dunfell,1/2] Revert "conf: machine: k3: Add fitImage to the default kernel image types" | expand

Commit Message

Jose Quaresma Dec. 13, 2022, 6:38 p.m. UTC
f8182afd optee: Upgrade to upstream 3.17.0
removes this patch but this is still required

Currently building with am62xx-evm/am64xx-evm machine fails with:

| aarch64-poky-linux-ld.bfd: cannot find libgcc.a: No such file or directory
| make: *** [ldelf/link.mk:60: out/arm-plat-k3/ldelf/ldelf.elf] Error 1
| make: *** Waiting for unfinished jobs....

Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
---
 ...ow-setting-sysroot-for-libgcc-lookup.patch | 34 +++++++++++++++++++
 recipes-security/optee/optee-os_%.bbappend    |  6 +++-
 2 files changed, 39 insertions(+), 1 deletion(-)
 create mode 100644 recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch
diff mbox series

Patch

diff --git a/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch b/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch
new file mode 100644
index 00000000..17005396
--- /dev/null
+++ b/recipes-security/optee/optee-os/0006-allow-setting-sysroot-for-libgcc-lookup.patch
@@ -0,0 +1,34 @@ 
+From 0bab935695ebcf0c533b49896ab18ff33d4a47d1 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@arm.com>
+Date: Tue, 26 May 2020 14:38:02 -0500
+Subject: [PATCH] allow setting sysroot for libgcc lookup
+
+Explicitly pass the new variable LIBGCC_LOCATE_CFLAGS variable when searching
+for the compiler libraries as there's no easy way to reliably pass --sysroot
+otherwise.
+
+Upstream-Status: Pending [https://github.com/OP-TEE/optee_os/issues/4188]
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+---
+ mk/gcc.mk | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/mk/gcc.mk b/mk/gcc.mk
+index adc77a24..81bfa78a 100644
+--- a/mk/gcc.mk
++++ b/mk/gcc.mk
+@@ -13,11 +13,11 @@ nostdinc$(sm)	:= -nostdinc -isystem $(shell $(CC$(sm)) \
+ 			-print-file-name=include 2> /dev/null)
+ 
+ # Get location of libgcc from gcc
+-libgcc$(sm)  	:= $(shell $(CC$(sm)) $(CFLAGS$(arch-bits-$(sm))) \
++libgcc$(sm)  	:= $(shell $(CC$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CFLAGS$(arch-bits-$(sm))) \
+ 			-print-libgcc-file-name 2> /dev/null)
+-libstdc++$(sm)	:= $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
++libstdc++$(sm)	:= $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
+ 			-print-file-name=libstdc++.a 2> /dev/null)
+-libgcc_eh$(sm)	:= $(shell $(CXX$(sm)) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
++libgcc_eh$(sm)	:= $(shell $(CXX$(sm)) $(LIBGCC_LOCATE_CFLAGS) $(CXXFLAGS$(arch-bits-$(sm))) $(comp-cxxflags$(sm)) \
+ 			-print-file-name=libgcc_eh.a 2> /dev/null)
+ 
+ # Define these to something to discover accidental use
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 751dc3d0..e8af0124 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -1,6 +1,10 @@ 
+FILESEXTRAPATHS_prepend_ti-soc := "${THISDIR}/${PN}:"
+
 PV_ti-soc = "3.19.0+git${SRCPV}"
 SRCREV_ti-soc = "d6c5d0037b46f46caf71d67d7825d4b722cbcddf"
-SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https"
+SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https \
+    file://0006-allow-setting-sysroot-for-libgcc-lookup.patch \
+"
 
 DEPENDS_append_ti-soc = " python3-cryptography-native"