diff mbox series

[1/2] meson: drop redundant is_debianlike() patch

Message ID 20221212152542.3762880-1-ross.burton@arm.com
State Accepted, archived
Commit af4200197948f4900761cb1db11680aeab286f92
Headers show
Series [1/2] meson: drop redundant is_debianlike() patch | expand

Commit Message

Ross Burton Dec. 12, 2022, 3:25 p.m. UTC
This patch disables is_debianlike() so that it always returns False in the
name of deterministic builds.  However, the caller default_libdir() then
looks at the host filesystem to decide if /usr/lib64 exists and will
return either lib or lib64, so it still isn't deterministic.

This is only used for the default libdir value and meson.bbclass
always passes an explicit --libdir, so this is moot.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 ...01-is_debianlike-always-return-False.patch | 27 -------------------
 meta/recipes-devtools/meson/meson_0.64.0.bb   |  1 -
 2 files changed, 28 deletions(-)
 delete mode 100644 meta/recipes-devtools/meson/meson/0001-is_debianlike-always-return-False.patch

Comments

Richard Purdie Dec. 12, 2022, 3:38 p.m. UTC | #1
On Mon, 2022-12-12 at 15:25 +0000, Ross Burton wrote:
> This patch disables is_debianlike() so that it always returns False in the
> name of deterministic builds.  However, the caller default_libdir() then
> looks at the host filesystem to decide if /usr/lib64 exists and will
> return either lib or lib64, so it still isn't deterministic.
> 
> This is only used for the default libdir value and meson.bbclass
> always passes an explicit --libdir, so this is moot.
> 
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  ...01-is_debianlike-always-return-False.patch | 27 -------------------
>  meta/recipes-devtools/meson/meson_0.64.0.bb   |  1 -
>  2 files changed, 28 deletions(-)
>  delete mode 100644 meta/recipes-devtools/meson/meson/0001-is_debianlike-always-return-False.patch
> 
> diff --git a/meta/recipes-devtools/meson/meson/0001-is_debianlike-always-return-False.patch b/meta/recipes-devtools/meson/meson/0001-is_debianlike-always-return-False.patch
> deleted file mode 100644
> index a9a32e2b7a1..00000000000
> --- a/meta/recipes-devtools/meson/meson/0001-is_debianlike-always-return-False.patch
> +++ /dev/null
> @@ -1,27 +0,0 @@
> -From 361f51c2c7685491186703e8f26be991ab698edc Mon Sep 17 00:00:00 2001
> -From: Alexander Kanavin <alex@linutronix.de>
> -Date: Mon, 18 Oct 2021 15:55:59 +0200
> -Subject: [PATCH] is_debianlike(): always return False
> -
> -Otherwise, host contamination happens.
> -
> -Upstream-Status: Inappropriate [oe-core specific]
> -Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> -
> ----
> - mesonbuild/utils/universal.py | 2 +-
> - 1 file changed, 1 insertion(+), 1 deletion(-)
> -
> -diff --git a/mesonbuild/utils/universal.py b/mesonbuild/utils/universal.py
> -index 570edd6..4119aa5 100644
> ---- a/mesonbuild/utils/universal.py
> -+++ b/mesonbuild/utils/universal.py
> -@@ -634,7 +634,7 @@ def is_cygwin() -> bool:
> - 
> - 
> - def is_debianlike() -> bool:
> --    return os.path.isfile('/etc/debian_version')
> -+    return False
> - 
> - 
> - def is_dragonflybsd() -> bool:

I have a nasty feeling that there may be meson users out there which
call into this as an API function :(

Cheers,

Richard
Ross Burton Dec. 12, 2022, 3:46 p.m. UTC | #2
On 12 Dec 2022, at 15:38, Richard Purdie <richard.purdie@linuxfoundation.org> wrote:
>> - def is_debianlike() -> bool:
>> --    return os.path.isfile('/etc/debian_version')
>> -+    return False
>> - 
>> - 
>> - def is_dragonflybsd() -> bool:
> 
> I have a nasty feeling that there may be meson users out there which
> call into this as an API function :(

It’s not an exposed API, so no packages can use it in a meson.build file.

Ross
diff mbox series

Patch

diff --git a/meta/recipes-devtools/meson/meson/0001-is_debianlike-always-return-False.patch b/meta/recipes-devtools/meson/meson/0001-is_debianlike-always-return-False.patch
deleted file mode 100644
index a9a32e2b7a1..00000000000
--- a/meta/recipes-devtools/meson/meson/0001-is_debianlike-always-return-False.patch
+++ /dev/null
@@ -1,27 +0,0 @@ 
-From 361f51c2c7685491186703e8f26be991ab698edc Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex@linutronix.de>
-Date: Mon, 18 Oct 2021 15:55:59 +0200
-Subject: [PATCH] is_debianlike(): always return False
-
-Otherwise, host contamination happens.
-
-Upstream-Status: Inappropriate [oe-core specific]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
-
----
- mesonbuild/utils/universal.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mesonbuild/utils/universal.py b/mesonbuild/utils/universal.py
-index 570edd6..4119aa5 100644
---- a/mesonbuild/utils/universal.py
-+++ b/mesonbuild/utils/universal.py
-@@ -634,7 +634,7 @@ def is_cygwin() -> bool:
- 
- 
- def is_debianlike() -> bool:
--    return os.path.isfile('/etc/debian_version')
-+    return False
- 
- 
- def is_dragonflybsd() -> bool:
diff --git a/meta/recipes-devtools/meson/meson_0.64.0.bb b/meta/recipes-devtools/meson/meson_0.64.0.bb
index 84c3c84515f..34a04d52ab6 100644
--- a/meta/recipes-devtools/meson/meson_0.64.0.bb
+++ b/meta/recipes-devtools/meson/meson_0.64.0.bb
@@ -15,7 +15,6 @@  SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/meson-${PV}.tar.gz \
            file://disable-rpath-handling.patch \
            file://0001-Make-CPU-family-warnings-fatal.patch \
            file://0002-Support-building-allarch-recipes-again.patch \
-           file://0001-is_debianlike-always-return-False.patch \
            file://0001-Check-for-clang-before-guessing-gcc-or-lcc.patch \
            "
 SRC_URI[sha256sum] = "c5e27e091c2a35b9049e152a6535045ebbd057253aeb67856de6ecbb7b917bab"