diff mbox series

[meta-gnome,PATCHv2] editorconfig: add recipe

Message ID 20221210070938.5979-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-gnome,PATCHv2] editorconfig: add recipe | expand

Commit Message

Markus Volk Dec. 10, 2022, 7:09 a.m. UTC
It is needed by gnome-text-editor

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../editorconfig/editorconfig-core-c_git.bb      | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/editorconfig/editorconfig-core-c_git.bb

Comments

Khem Raj Dec. 10, 2022, 7:37 a.m. UTC | #1
On Fri, Dec 9, 2022 at 11:09 PM Markus Volk <f_l_k@t-online.de> wrote:
>
> It is needed by gnome-text-editor
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  .../editorconfig/editorconfig-core-c_git.bb      | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>  create mode 100644 meta-oe/recipes-devtools/editorconfig/editorconfig-core-c_git.bb
>
> diff --git a/meta-oe/recipes-devtools/editorconfig/editorconfig-core-c_git.bb b/meta-oe/recipes-devtools/editorconfig/editorconfig-core-c_git.bb
> new file mode 100644
> index 000000000..8c8ce6e34
> --- /dev/null
> +++ b/meta-oe/recipes-devtools/editorconfig/editorconfig-core-c_git.bb
> @@ -0,0 +1,16 @@
> +SUMMARY = "EditorConfig helps maintain consistent coding styles across various editors and IDEs."
> +HOMEPAGE = "https://https://editorconfig.org"
> +SECTION = "libs"
> +LICENSE = "BSD-2-Clause"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=f515fff3ea0a2b9797eda60d83c0e5ca"
> +
> +SRC_URI = "git://github.com/editorconfig/editorconfig-core-c.git;protocol=https;branch=master"
> +
> +S = "${WORKDIR}/git"
> +PV = "0.12.5"

its better to call the recipe with PV and drop setting PV here.

> +SRCREV = "f6b0ca395149b5a2fbd56a488cae30306a58170f"
> +
> +inherit cmake
> +
> +DEPENDS = "pcre2"
> +
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#100020): https://lists.openembedded.org/g/openembedded-devel/message/100020
> Mute This Topic: https://lists.openembedded.org/mt/95578135/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/editorconfig/editorconfig-core-c_git.bb b/meta-oe/recipes-devtools/editorconfig/editorconfig-core-c_git.bb
new file mode 100644
index 000000000..8c8ce6e34
--- /dev/null
+++ b/meta-oe/recipes-devtools/editorconfig/editorconfig-core-c_git.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "EditorConfig helps maintain consistent coding styles across various editors and IDEs."
+HOMEPAGE = "https://https://editorconfig.org"
+SECTION = "libs"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f515fff3ea0a2b9797eda60d83c0e5ca"
+
+SRC_URI = "git://github.com/editorconfig/editorconfig-core-c.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+PV = "0.12.5"
+SRCREV = "f6b0ca395149b5a2fbd56a488cae30306a58170f"
+
+inherit cmake
+
+DEPENDS = "pcre2"
+