diff mbox series

[meta-oe,1/3] frame: add opengl to REQUIRED_DISTRO_FEATURES

Message ID 20221210051840.103991-1-mingli.yu@eng.windriver.com
State Under Review
Headers show
Series [meta-oe,1/3] frame: add opengl to REQUIRED_DISTRO_FEATURES | expand

Commit Message

mingli.yu@eng.windriver.com Dec. 10, 2022, 5:18 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

Fixes:
  ERROR: Nothing PROVIDES 'virtual/xserver' (but /build/layers/meta-openembedded/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb DEPENDS on or otherwise requires it)
xserver-xorg PROVIDES virtual/xserver but was skipped: missing required distro feature 'opengl' (not in DISTRO_FEATURES)
  ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
  Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'geis', 'frame', 'virtual/xserver']

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb b/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb
index 3ccd9a137..bf62e8416 100644
--- a/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb
@@ -8,7 +8,9 @@  LIC_FILES_CHKSUM = " \
     file://COPYING.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
 "
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig features_check
+
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'opengl', '', d)}"
 
 SRC_URI = "https://launchpad.net/${BPN}/trunk/v${PV}/+download/${BPN}-${PV}.tar.gz \
            file://pessimizing-move.patch"