diff mbox series

[meta-oe,1/2] xf86-video-amdgpu: add opengl to REQUIRED_DISTRO_FEATURES

Message ID 20221209100504.660239-1-mingli.yu@eng.windriver.com
State Under Review
Headers show
Series [meta-oe,1/2] xf86-video-amdgpu: add opengl to REQUIRED_DISTRO_FEATURES | expand

Commit Message

mingli.yu@eng.windriver.com Dec. 9, 2022, 10:05 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

Fix the below yocto compliance issue:
  ERROR: Nothing PROVIDES 'virtual/libgbm' (but /build/layers/meta-openembedded/meta-oe/recipes-graphics/xorg-driver/xf86-video-amdgpu_22.0.0.bb DEPENDS on or otherwise requires it). Close matches:
  virtual/libc
  virtual/libomxil
  virtual/libusb0
  ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
  Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'xf86-video-amdgpu', 'virtual/libgbm']

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 .../recipes-graphics/xorg-driver/xf86-video-amdgpu_22.0.0.bb    | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-amdgpu_22.0.0.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-amdgpu_22.0.0.bb
index 94e2ea43e..3082e2e6b 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-amdgpu_22.0.0.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-amdgpu_22.0.0.bb
@@ -12,6 +12,8 @@  SRC_URI[sha256sum] = "bc47a1a8854e790270fa5de2fb9dfe8558139b03d8f68ac1057dcd235d
 XORG_DRIVER_COMPRESSOR = ".tar.gz"
 DEPENDS += "virtual/libx11 libdrm virtual/libgbm xorgproto"
 
+REQUIRED_DISTRO_FEATURES += "opengl"
+
 PACKAGECONFIG ??= "udev glamor"
 PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
 PACKAGECONFIG[glamor] = "--enable-glamor,--disable-glamor"