[v2] python3-pyelftools: Depend on debugger, pprint

Message ID 20211216235825.32536-1-chaitanya.vadrevu@ni.com
State Accepted, archived
Commit 22e84cdd05870f1a19c6389b66c4dfd5e9b418f7
Headers show
Series [v2] python3-pyelftools: Depend on debugger, pprint | expand

Commit Message

Chaitanya Vadrevu Dec. 16, 2021, 11:58 p.m. UTC
python3-pyelftools uses python3-debugger, python3-pprint.
So add dependencies on these packages.

Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
---
 meta/recipes-devtools/python/python3-pyelftools_0.27.bb | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
index 0cfd99504b..e2d0e18277 100644
--- a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
+++ b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
@@ -11,3 +11,5 @@  PYPI_PACKAGE = "pyelftools"
 inherit pypi setuptools3
 
 BBCLASSEXTEND = "native"
+
+RDEPENDS:${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"