[meta-oe,v2] libbytesize: Add depends for gettext-native

Submitted by Jason Wessel on July 11, 2019, 9:48 p.m. | Patch ID: 163002

Details

Message ID 20190711214836.123757-1-jason.wessel@windriver.com
State Accepted
Commit da057468d72cbb897e655507aa4401b14005b9a7
Headers show

Commit Message

Jason Wessel July 11, 2019, 9:48 p.m.
If the local.conf has set 'USE_NLS = "no"' the build of libbytesize
will fail with the following message:

| configure: error: in `/build/tmp/work/core2-64-poky-linux/libbytesize/2.0-r0/build':
| configure: error: gettext not found
| See `config.log' for more details
| NOTE: The following config.log files may provide further information.
| NOTE: /build/tmp/work/core2-64-poky-linux/libbytesize/2.0-r0/build/config.log
| ERROR: configure failed

The issue is that libbytesize needs to full version of gettext in
order to configure properly, and not the minimal version which is
provided by default when building with 'USE_NLS = "no"'.

Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
---
 meta-oe/recipes-support/libbytesize/libbytesize_2.0.bb | 1 +
 1 file changed, 1 insertion(+)

Patch hide | download patch | download mbox

diff --git a/meta-oe/recipes-support/libbytesize/libbytesize_2.0.bb b/meta-oe/recipes-support/libbytesize/libbytesize_2.0.bb
index 1beb6777e..74f1800d1 100644
--- a/meta-oe/recipes-support/libbytesize/libbytesize_2.0.bb
+++ b/meta-oe/recipes-support/libbytesize/libbytesize_2.0.bb
@@ -20,6 +20,7 @@  DEPENDS += " \
     libpcre2 \
     gmp \
     mpfr \
+    gettext-native \
 "
 
 FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"