diff mbox series

['meta-python,V2',1/2] python3-binwalk: add recipe for version 2.3.3

Message ID 20221201082430.1569827-1-tomasz.zyjewski@3mdeb.com
State New
Headers show
Series ['meta-python,V2',1/2] python3-binwalk: add recipe for version 2.3.3 | expand

Commit Message

Tomasz Żyjewski Dec. 1, 2022, 8:24 a.m. UTC
Install binwalk utility.

Binwalk is a fast, easy to use tool for analyzing, reverse engineering,
and extracting firmware images.

Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
---
 .../python/python3-binwalk_2.3.3.bb             | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
new file mode 100644
index 000000000000..362efa275148
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Firmware analysis tool"
+DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a fast, \
+easy to use tool for analyzing, reverse engineering, and extracting firmware \
+images."
+HOMEPAGE = "https://github.com/ReFirmLabs/binwalk"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
+
+SRC_URI = "git://github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
+
+SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += "python3-core"