[test,V2] patchtest: fix linux-yocto version

Submitted by changqing.li@windriver.com on June 13, 2019, 9:16 a.m. | Patch ID: 162179

Details

Message ID 1560417380-358445-1-git-send-email-changqing.li@windriver.com
State New
Headers show

Commit Message

changqing.li@windriver.com June 13, 2019, 9:16 a.m.
From: Changqing Li <changqing.li@windriver.com>

4.9 is not avaiable currently, so remove version from bbappend
and remove PREFERRED_VERSION.

Signed-off-by: Changqing Li <changqing.li@windriver.com>
---
 .../linux/{linux-yocto_4.%.bbappend => linux-yocto_%.bbappend}       | 0
 scripts/create-guest-machine                                         | 5 -----
 2 files changed, 5 deletions(-)
 rename meta-patchtest/recipes-kernel/linux/{linux-yocto_4.%.bbappend => linux-yocto_%.bbappend} (100%)

Patch hide | download patch | download mbox

diff --git a/meta-patchtest/recipes-kernel/linux/linux-yocto_4.%.bbappend b/meta-patchtest/recipes-kernel/linux/linux-yocto_%.bbappend
similarity index 100%
rename from meta-patchtest/recipes-kernel/linux/linux-yocto_4.%.bbappend
rename to meta-patchtest/recipes-kernel/linux/linux-yocto_%.bbappend
diff --git a/scripts/create-guest-machine b/scripts/create-guest-machine
index 8dd6a2e..8381ef8 100755
--- a/scripts/create-guest-machine
+++ b/scripts/create-guest-machine
@@ -145,11 +145,6 @@  cat >> $POKY/build/conf/auto.conf << EOF
 $PTSMARK
 MACHINE = "$MACHINE"
 
-# The preferred kernel version in poky (4.10%, master) returns an error whilst
-# executing patchtest on guest. Changing the preferred version to 4.9% as it
-# is more suitable and does not present any errors.
-PREFERRED_VERSION_linux-yocto_qemux86-64 = "4.9%"
-
 PACKAGE_CLASSES = "package_ipk"
 IMAGE_FSTYPES = "ext4"
 SSTATE_MIRRORS ?= "file://.* http://sstate.yoctoproject.org/dev/PATH"

Comments

changqing.li@windriver.com Aug. 14, 2019, 2:26 a.m.
Hi, Richard

This patchset need to be merged.

patchtest: fix linux-yocto version

and patchtest: fix virtio-9p-pci is not a valid device


Thanks

On 6/13/19 5:16 PM, changqing.li@windriver.com wrote:
> From: Changqing Li <changqing.li@windriver.com>
>
> 4.9 is not avaiable currently, so remove version from bbappend
> and remove PREFERRED_VERSION.
>
> Signed-off-by: Changqing Li <changqing.li@windriver.com>
> ---
>   .../linux/{linux-yocto_4.%.bbappend => linux-yocto_%.bbappend}       | 0
>   scripts/create-guest-machine                                         | 5 -----
>   2 files changed, 5 deletions(-)
>   rename meta-patchtest/recipes-kernel/linux/{linux-yocto_4.%.bbappend => linux-yocto_%.bbappend} (100%)
>
> diff --git a/meta-patchtest/recipes-kernel/linux/linux-yocto_4.%.bbappend b/meta-patchtest/recipes-kernel/linux/linux-yocto_%.bbappend
> similarity index 100%
> rename from meta-patchtest/recipes-kernel/linux/linux-yocto_4.%.bbappend
> rename to meta-patchtest/recipes-kernel/linux/linux-yocto_%.bbappend
> diff --git a/scripts/create-guest-machine b/scripts/create-guest-machine
> index 8dd6a2e..8381ef8 100755
> --- a/scripts/create-guest-machine
> +++ b/scripts/create-guest-machine
> @@ -145,11 +145,6 @@ cat >> $POKY/build/conf/auto.conf << EOF
>   $PTSMARK
>   MACHINE = "$MACHINE"
>   
> -# The preferred kernel version in poky (4.10%, master) returns an error whilst
> -# executing patchtest on guest. Changing the preferred version to 4.9% as it
> -# is more suitable and does not present any errors.
> -PREFERRED_VERSION_linux-yocto_qemux86-64 = "4.9%"
> -
>   PACKAGE_CLASSES = "package_ipk"
>   IMAGE_FSTYPES = "ext4"
>   SSTATE_MIRRORS ?= "file://.* http://sstate.yoctoproject.org/dev/PATH"