[test,2/2] patchtest: fix linux-yocto version

Submitted by changqing.li@windriver.com on June 13, 2019, 7:46 a.m. | Patch ID: 162174

Details

Message ID 1560411964-388665-2-git-send-email-changqing.li@windriver.com
State Superseded
Headers show

Commit Message

changqing.li@windriver.com June 13, 2019, 7:46 a.m.
From: Changqing Li <changqing.li@windriver.com>

4.9 is not avaiable currently, preferred version changed
to 5.0, also correct the bbappend name

Signed-off-by: Changqing Li <changqing.li@windriver.com>
---
 .../linux/{linux-yocto_4.%.bbappend => linux-yocto_%.bbappend}       | 0
 scripts/create-guest-machine                                         | 5 +----
 2 files changed, 1 insertion(+), 4 deletions(-)
 rename meta-patchtest/recipes-kernel/linux/{linux-yocto_4.%.bbappend => linux-yocto_%.bbappend} (100%)

Patch hide | download patch | download mbox

diff --git a/meta-patchtest/recipes-kernel/linux/linux-yocto_4.%.bbappend b/meta-patchtest/recipes-kernel/linux/linux-yocto_%.bbappend
similarity index 100%
rename from meta-patchtest/recipes-kernel/linux/linux-yocto_4.%.bbappend
rename to meta-patchtest/recipes-kernel/linux/linux-yocto_%.bbappend
diff --git a/scripts/create-guest-machine b/scripts/create-guest-machine
index 8dd6a2e..151d5c2 100755
--- a/scripts/create-guest-machine
+++ b/scripts/create-guest-machine
@@ -145,10 +145,7 @@  cat >> $POKY/build/conf/auto.conf << EOF
 $PTSMARK
 MACHINE = "$MACHINE"
 
-# The preferred kernel version in poky (4.10%, master) returns an error whilst
-# executing patchtest on guest. Changing the preferred version to 4.9% as it
-# is more suitable and does not present any errors.
-PREFERRED_VERSION_linux-yocto_qemux86-64 = "4.9%"
+PREFERRED_VERSION_linux-yocto_qemux86-64 = "5.0%"
 
 PACKAGE_CLASSES = "package_ipk"
 IMAGE_FSTYPES = "ext4"

Comments

Adrian Bunk June 13, 2019, 8:29 a.m.
On Thu, Jun 13, 2019 at 03:46:04PM +0800, changqing.li@windriver.com wrote:
> From: Changqing Li <changqing.li@windriver.com>
> 
> 4.9 is not avaiable currently, preferred version changed
> to 5.0, also correct the bbappend name

5.0 is already EOL upstream and will be removed soon.

>...
> --- a/scripts/create-guest-machine
> +++ b/scripts/create-guest-machine
> @@ -145,10 +145,7 @@ cat >> $POKY/build/conf/auto.conf << EOF
>  $PTSMARK
>  MACHINE = "$MACHINE"
>  
> -# The preferred kernel version in poky (4.10%, master) returns an error whilst
> -# executing patchtest on guest. Changing the preferred version to 4.9% as it
> -# is more suitable and does not present any errors.
> -PREFERRED_VERSION_linux-yocto_qemux86-64 = "4.9%"
> +PREFERRED_VERSION_linux-yocto_qemux86-64 = "5.0%"
>...

This looks as if it was a temporary workaround for some problem with 
kernel 4.10.

If 5.0 works, then there is not really a reason for changing the 
preferred version here.

cu
Adrian
changqing.li@windriver.com June 13, 2019, 8:36 a.m.
On 6/13/19 4:29 PM, Adrian Bunk wrote:
> On Thu, Jun 13, 2019 at 03:46:04PM +0800, changqing.li@windriver.com wrote:
>> From: Changqing Li <changqing.li@windriver.com>
>>
>> 4.9 is not avaiable currently, preferred version changed
>> to 5.0, also correct the bbappend name
> 5.0 is already EOL upstream and will be removed soon.
>
>> ...
>> --- a/scripts/create-guest-machine
>> +++ b/scripts/create-guest-machine
>> @@ -145,10 +145,7 @@ cat >> $POKY/build/conf/auto.conf << EOF
>>   $PTSMARK
>>   MACHINE = "$MACHINE"
>>   
>> -# The preferred kernel version in poky (4.10%, master) returns an error whilst
>> -# executing patchtest on guest. Changing the preferred version to 4.9% as it
>> -# is more suitable and does not present any errors.
>> -PREFERRED_VERSION_linux-yocto_qemux86-64 = "4.9%"
>> +PREFERRED_VERSION_linux-yocto_qemux86-64 = "5.0%"
>> ...
> This looks as if it was a temporary workaround for some problem with
> kernel 4.10.
>
> If 5.0 works, then there is not really a reason for changing the
> preferred version here.
Thanks, I will remove this line.
>
> cu
> Adrian
>
changqing.li@windriver.com June 13, 2019, 7:17 p.m.
This is a system generated Comment: Patch 162174 was automatically marked as superseded by patch 162179.