[meta-networking] python-ldap: add python-pyasn1 and python-pyasn1-modules as runtime dependencies

Submitted by Yi Zhao on June 4, 2019, 1:52 a.m. | Patch ID: 161944

Details

Message ID 1559613157-28527-1-git-send-email-yi.zhao@windriver.com
State Accepted
Commit 5d1e72d9f79cb8b064dad6baf50bb2ca33d2ce32
Headers show

Commit Message

Yi Zhao June 4, 2019, 1:52 a.m.
According to Doc/requirements.txt, this package needs python-pyasn1 and
python-pyasn1-modules as runtime dependencies.

Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
---
 meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb | 2 ++
 1 file changed, 2 insertions(+)

Patch hide | download patch | download mbox

diff --git a/meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb b/meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb
index d10f11b..af8961e 100644
--- a/meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb
+++ b/meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb
@@ -26,4 +26,6 @@  do_configure_prepend() {
 RDEPENDS_${PN} = " \
     ${PYTHON_PN}-pprint \
     ${PYTHON_PN}-threading \
+    ${PYTHON_PN}-pyasn1 \
+    ${PYTHON_PN}-pyasn1-modules \
 "

Comments

Tim Orling June 7, 2019, 7:17 a.m.
This recipe needs a python3 version as well. Python2 will be EOL soon.

On Mon, Jun 3, 2019 at 6:53 PM Yi Zhao <yi.zhao@windriver.com> wrote:

> According to Doc/requirements.txt, this package needs python-pyasn1 and
> python-pyasn1-modules as runtime dependencies.
>
> Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
> ---
>  meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb
> b/meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb
> index d10f11b..af8961e 100644
> --- a/meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb
> +++ b/meta-networking/recipes-devtools/python/python-ldap_3.2.0.bb
> @@ -26,4 +26,6 @@ do_configure_prepend() {
>  RDEPENDS_${PN} = " \
>      ${PYTHON_PN}-pprint \
>      ${PYTHON_PN}-threading \
> +    ${PYTHON_PN}-pyasn1 \
> +    ${PYTHON_PN}-pyasn1-modules \
>  "
> --
> 2.7.4
>
> --
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
>