diff mbox series

[meta-ti,dunfell] optee-os: Update SRCREV for OP-TEE TRNG in AM62X

Message ID 20221128054627.131772-1-j-choudhary@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,dunfell] optee-os: Update SRCREV for OP-TEE TRNG in AM62X | expand

Commit Message

Jayesh Choudhary Nov. 28, 2022, 5:46 a.m. UTC
From: Kamlesh Gurudasani <kamlesh@ti.com>

Update the SRCREV to the commit when trng support was
added in upstream OP-TEE for am62x platform to access rng.

Also, enable trng support as trng support is added now in OP-TEE

Signed-off-by: Kamlesh Gurudasani <kamlesh@ti.com>
Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>
---

HS-UART-logs:
http://serenity.dal.design.ti.com:7777/habajarafo.yaml

GP-DFU-logs:
http://serenity.dal.design.ti.com:7777/atejarexak.yaml

 recipes-security/optee/optee-os_%.bbappend | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

Comments

Andrew Davis Nov. 28, 2022, 3:50 p.m. UTC | #1
On 11/27/22 11:46 PM, Jayesh Choudhary wrote:
> From: Kamlesh Gurudasani <kamlesh@ti.com>
> 
> Update the SRCREV to the commit when trng support was
> added in upstream OP-TEE for am62x platform to access rng.
> 
> Also, enable trng support as trng support is added now in OP-TEE
> 
> Signed-off-by: Kamlesh Gurudasani <kamlesh@ti.com>
> Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>

Looks good, same is needed for kirkstone/master branches.

Acked-by: Andrew Davis <afd@ti.com>

> ---
> 
> HS-UART-logs:
> http://serenity.dal.design.ti.com:7777/habajarafo.yaml
> 
> GP-DFU-logs:
> http://serenity.dal.design.ti.com:7777/atejarexak.yaml
> 
>   recipes-security/optee/optee-os_%.bbappend | 5 +----
>   1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
> index 2b591d58..751dc3d0 100644
> --- a/recipes-security/optee/optee-os_%.bbappend
> +++ b/recipes-security/optee/optee-os_%.bbappend
> @@ -1,14 +1,11 @@
>   PV_ti-soc = "3.19.0+git${SRCPV}"
> -SRCREV_ti-soc = "afacf356f9593a7f83cae9f96026824ec242ff52"
> +SRCREV_ti-soc = "d6c5d0037b46f46caf71d67d7825d4b722cbcddf"
>   SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https"
>   
>   DEPENDS_append_ti-soc = " python3-cryptography-native"
>   
>   EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
>   
> -EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
> -EXTRA_OEMAKE_append_am62xx-lp-evm = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
> -
>   do_compile_prepend_ti-soc() {
>       export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
>   }
diff mbox series

Patch

diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 2b591d58..751dc3d0 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -1,14 +1,11 @@ 
 PV_ti-soc = "3.19.0+git${SRCPV}"
-SRCREV_ti-soc = "afacf356f9593a7f83cae9f96026824ec242ff52"
+SRCREV_ti-soc = "d6c5d0037b46f46caf71d67d7825d4b722cbcddf"
 SRC_URI_ti-soc = "git://github.com/OP-TEE/optee_os.git;protocol=https"
 
 DEPENDS_append_ti-soc = " python3-cryptography-native"
 
 EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
 
-EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
-EXTRA_OEMAKE_append_am62xx-lp-evm = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
-
 do_compile_prepend_ti-soc() {
     export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
 }