diff mbox series

[3/5] util-linux: add selinux PACKAGECONFIG

Message ID 20221124101713.1789943-3-mingli.yu@eng.windriver.com
State Accepted, archived
Commit c57cc22fad708ac856ac4ebe0a42042031fbf90b
Headers show
Series [1/5] sudo: add selinux and audit PACKAGECONFIG | expand

Commit Message

mingli.yu@eng.windriver.com Nov. 24, 2022, 10:17 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

Add selinux PACKAGECONFIG logic in selinux layer[1] to conform
to yocto compliance.

[1] https://git.yoctoproject.org/meta-selinux/commit/?id=31325005e4409e08b7f68eed44a9c4086453e4dd

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta/recipes-core/util-linux/util-linux_2.38.1.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta/recipes-core/util-linux/util-linux_2.38.1.bb b/meta/recipes-core/util-linux/util-linux_2.38.1.bb
index 50ecc106dd..9ea7a04e8a 100644
--- a/meta/recipes-core/util-linux/util-linux_2.38.1.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.38.1.bb
@@ -107,6 +107,7 @@  PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
 PACKAGECONFIG[pcre2] = ",,libpcre2"
 PACKAGECONFIG[cryptsetup] = "--with-cryptsetup,--without-cryptsetup,cryptsetup"
 PACKAGECONFIG[chfn-chsh] = "--enable-chfn-chsh,--disable-chfn-chsh,"
+PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
 
 EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} CPU= CPUOPT= 'OPT=${CFLAGS}'"