[meta-networking] Fix the libnm* packages

Submitted by Adrian Bunk on Jan. 30, 2019, 9:52 a.m. | Patch ID: 158363

Details

Message ID 20190130095201.11965-2-bunk@stusta.de
State Rejected
Commit a73abc8253d7f6ae390c33bad6575a7b3cc86b8b
Headers show

Commit Message

Adrian Bunk Jan. 30, 2019, 9:52 a.m.
- libnmutil, libnmglib and libnmglib-vpn no longer exist
  after the 1.10.10 -> 1.14.4 upgrade
- add a package for libnm

Signed-off-by: Adrian Bunk <bunk@stusta.de>
---
 .../recipes-connectivity/networkmanager/networkmanager_1.14.4.bb    | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

Patch hide | download patch | download mbox

diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
index f1826c68e..9efe1fe49 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
@@ -90,14 +90,12 @@  PACKAGECONFIG[wifi] = "--enable-wifi=yes,--enable-wifi=no,,wpa-supplicant"
 PACKAGECONFIG[ifupdown] = "--enable-ifupdown,--disable-ifupdown"
 PACKAGECONFIG[qt4-x11-free] = "--enable-qt,--disable-qt,qt4-x11-free"
 
-PACKAGES =+ "libnmutil libnmglib libnmglib-vpn \
+PACKAGES =+ "libnm \
   ${PN}-nmtui ${PN}-nmtui-doc \
   ${PN}-adsl \
 "
 
-FILES_libnmutil += "${libdir}/libnm-util.so.*"
-FILES_libnmglib += "${libdir}/libnm-glib.so.*"
-FILES_libnmglib-vpn += "${libdir}/libnm-glib-vpn.so.*"
+FILES_libnm += "${libdir}/libnm.so.*"
 
 FILES_${PN}-adsl = "${libdir}/NetworkManager/libnm-device-plugin-adsl.so"
 

Comments

Andreas Müller Jan. 30, 2019, 10:31 p.m.
On Wed, Jan 30, 2019 at 10:52 AM Adrian Bunk <bunk@stusta.de> wrote:
>
> - libnmutil, libnmglib and libnmglib-vpn no longer exist
>   after the 1.10.10 -> 1.14.4 upgrade
Checked (OK am on thud environment) but it is 1.14.4. All packages you
want to remove contain files on my build! Are you sure that you have
the required PACKAGECONFIGS set (please set all and test) and the
nasty new 'polkit' in your distro features?

So Khem - have seen this on master-next - please block this one - I
expect fallout.

Andreas


> - add a package for libnm
>
> Signed-off-by: Adrian Bunk <bunk@stusta.de>
> ---
>  .../recipes-connectivity/networkmanager/networkmanager_1.14.4.bb    | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
> index f1826c68e..9efe1fe49 100644
> --- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
> +++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.14.4.bb
> @@ -90,14 +90,12 @@ PACKAGECONFIG[wifi] = "--enable-wifi=yes,--enable-wifi=no,,wpa-supplicant"
>  PACKAGECONFIG[ifupdown] = "--enable-ifupdown,--disable-ifupdown"
>  PACKAGECONFIG[qt4-x11-free] = "--enable-qt,--disable-qt,qt4-x11-free"
>
> -PACKAGES =+ "libnmutil libnmglib libnmglib-vpn \
> +PACKAGES =+ "libnm \
>    ${PN}-nmtui ${PN}-nmtui-doc \
>    ${PN}-adsl \
>  "
>
> -FILES_libnmutil += "${libdir}/libnm-util.so.*"
> -FILES_libnmglib += "${libdir}/libnm-glib.so.*"
> -FILES_libnmglib-vpn += "${libdir}/libnm-glib-vpn.so.*"
> +FILES_libnm += "${libdir}/libnm.so.*"
>
>  FILES_${PN}-adsl = "${libdir}/NetworkManager/libnm-device-plugin-adsl.so"
>
> --
> 2.11.0
>
> --
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
Adrian Bunk Jan. 31, 2019, 6:10 p.m.
On Wed, Jan 30, 2019 at 11:31:52PM +0100, Andreas Müller wrote:
> On Wed, Jan 30, 2019 at 10:52 AM Adrian Bunk <bunk@stusta.de> wrote:
> >
> > - libnmutil, libnmglib and libnmglib-vpn no longer exist
> >   after the 1.10.10 -> 1.14.4 upgrade
> Checked (OK am on thud environment) but it is 1.14.4. All packages you
> want to remove contain files on my build! Are you sure that you have
> the required PACKAGECONFIGS set (please set all and test) and the
> nasty new 'polkit' in your distro features?
>...

Thanks for spotting my mistake.

The problem is actually not related to polkit, my mistake was due to the 
glib PACKAGECONFIG: I misremembered that it was removed in NM 1.12, but
it is actually only strongly deprecated (and no longer shipped in 
distributions like Debian/Ubuntu).

> Andreas

cu
Adrian