[meta-security,03/11] apparmor: add missing bash dependency

Submitted by Ross Burton on Jan. 14, 2019, 2:42 p.m. | Patch ID: 157859

Details

Message ID 20190114144208.14353-3-ross.burton@intel.com
State New
Headers show

Commit Message

Ross Burton Jan. 14, 2019, 2:42 p.m.
testsuite/parser/tst/minimize.sh is a bash script, so until it is reviewed add a
bash dependency to apparmor-ptest.

Signed-off-by: Ross Burton <ross.burton@intel.com>
---
 recipes-security/AppArmor/apparmor_2.12.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch hide | download patch | download mbox

diff --git a/recipes-security/AppArmor/apparmor_2.12.bb b/recipes-security/AppArmor/apparmor_2.12.bb
index e3f8dc9..2cf5b7d 100644
--- a/recipes-security/AppArmor/apparmor_2.12.bb
+++ b/recipes-security/AppArmor/apparmor_2.12.bb
@@ -156,4 +156,4 @@  ALLOW_EMPTY_${PN} = "1"
 RDEPENDS_${PN} += "bash lsb"
 RDEPENDS_${PN} += "${@bb.utils.contains('PACKAGECONFIG','python','python3 python3-modules','', d)}"
 RDEPENDS_${PN}_remove += "${@bb.utils.contains('PACKAGECONFIG','perl','','perl', d)}"
-RDEPENDS_${PN}-ptest += "perl coreutils dbus-lib"
+RDEPENDS_${PN}-ptest += "perl coreutils dbus-lib bash"