[meta-oe,1/2] libgpiod_1.2: add dependency on python when building python bindings

Submitted by Khem Raj on Jan. 8, 2019, 10:05 p.m. | Patch ID: 157636

Details

Message ID 20190108220512.44077-1-raj.khem@gmail.com
State Accepted
Commit c44679b4942a30ac89013343f987403ec63f0ece
Headers show

Commit Message

Khem Raj Jan. 8, 2019, 10:05 p.m.
From: Ferry <ftoth@telfort.nl>

Commit ab54dd75 "libgpiod: Rrecommend python3 only for PN-python package" also removes the build dependency
on python3 however this results in fatal error: Python.h: No such file or directory #include <Python.h>

Signed-off-by: Ferry Toth <ftoth@exalondelft.nl>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-support/libgpiod/libgpiod_1.2.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch hide | download patch | download mbox

diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.2.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.2.bb
index dd080ff9d2..93165a0c2d 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.2.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.2.bb
@@ -7,7 +7,7 @@  SRC_URI[sha256sum] = "b6b9079c933f7c8524815437937dda6b795a16141bca202a9eec70ba58
 
 PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
 
-PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,"
+PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
 inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)}
 
 PACKAGES =+ "${PN}-python"