swig: Fix the build

Submitted by Alistair Francis on Jan. 3, 2019, 10:30 p.m. | Patch ID: 157551

Details

Message ID 20190103223016.17799-1-alistair.francis@wdc.com
State New
Headers show

Commit Message

Alistair Francis Jan. 3, 2019, 10:30 p.m.
Fix the swig build by calling autogen.sh before running configure.

Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
---
 meta/recipes-devtools/swig/swig.inc | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Patch hide | download patch | download mbox

diff --git a/meta/recipes-devtools/swig/swig.inc b/meta/recipes-devtools/swig/swig.inc
index aec544997f..49da68c544 100644
--- a/meta/recipes-devtools/swig/swig.inc
+++ b/meta/recipes-devtools/swig/swig.inc
@@ -11,7 +11,7 @@  DEPENDS = "libpcre"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
 
-inherit autotools python3native pkgconfig
+inherit autotools-brokensep python3native pkgconfig
 
 EXTRA_OECONF = " \
     --with-python3=${PYTHON} \
@@ -45,6 +45,7 @@  do_configure() {
     install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/Tools/config
     install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
     install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
+    ./autogen.sh
     oe_runconf
 }
 

Comments

Khem Raj Jan. 3, 2019, 10:32 p.m.
On Thu, Jan 3, 2019 at 2:30 PM Alistair Francis
<Alistair.Francis@wdc.com> wrote:
>
> Fix the swig build by calling autogen.sh before running configure.
>
> Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
> ---
>  meta/recipes-devtools/swig/swig.inc | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-devtools/swig/swig.inc b/meta/recipes-devtools/swig/swig.inc
> index aec544997f..49da68c544 100644
> --- a/meta/recipes-devtools/swig/swig.inc
> +++ b/meta/recipes-devtools/swig/swig.inc
> @@ -11,7 +11,7 @@ DEPENDS = "libpcre"
>
>  SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
>
> -inherit autotools python3native pkgconfig
> +inherit autotools-brokensep python3native pkgconfig

this seems to be going backwards.

>
>  EXTRA_OECONF = " \
>      --with-python3=${PYTHON} \
> @@ -45,6 +45,7 @@ do_configure() {
>      install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/Tools/config
>      install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
>      install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
> +    ./autogen.sh

may be just (cd ${S} && ./autogen.sh)

>      oe_runconf
>  }
>
> --
> 2.19.1
>
> --
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-core
Alistair Francis Jan. 3, 2019, 10:56 p.m.
On Thu, Jan 3, 2019 at 2:33 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Thu, Jan 3, 2019 at 2:30 PM Alistair Francis
> <Alistair.Francis@wdc.com> wrote:
> >
> > Fix the swig build by calling autogen.sh before running configure.
> >
> > Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
> > ---
> >  meta/recipes-devtools/swig/swig.inc | 3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-devtools/swig/swig.inc b/meta/recipes-devtools/swig/swig.inc
> > index aec544997f..49da68c544 100644
> > --- a/meta/recipes-devtools/swig/swig.inc
> > +++ b/meta/recipes-devtools/swig/swig.inc
> > @@ -11,7 +11,7 @@ DEPENDS = "libpcre"
> >
> >  SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
> >
> > -inherit autotools python3native pkgconfig
> > +inherit autotools-brokensep python3native pkgconfig
>
> this seems to be going backwards.
>
> >
> >  EXTRA_OECONF = " \
> >      --with-python3=${PYTHON} \
> > @@ -45,6 +45,7 @@ do_configure() {
> >      install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/Tools/config
> >      install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
> >      install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
> > +    ./autogen.sh
>
> may be just (cd ${S} && ./autogen.sh)

That seems to work, I'll send a v2.

Alistair

>
> >      oe_runconf
> >  }
> >
> > --
> > 2.19.1
> >
> > --
> > _______________________________________________
> > Openembedded-core mailing list
> > Openembedded-core@lists.openembedded.org
> > http://lists.openembedded.org/mailman/listinfo/openembedded-core
> --
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-core