[thud,1/2] libaio: Extend to native

Submitted by Peter Kjellerstedt on Dec. 22, 2018, 10:13 p.m. | Patch ID: 157392

Details

Message ID 20181222221322.3768-1-pkj@axis.com
State Thud Next
Delegated to: Armin Kuster
Headers show

Commit Message

Peter Kjellerstedt Dec. 22, 2018, 10:13 p.m.
From: Peter Kjellerstedt <peter.kjellerstedt@axis.com>

lvm2 currently requires libaio. So building lvm2-native will result in
the following error.

  ERROR: Required build target 'lvm2-native' has no buildable providers.
  Missing or unbuildable dependency chain was: ['lvm2-native', 'libaio-native']

Extend libaio to native to fix this issue.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---

This is a backport from master.

 meta/recipes-extended/libaio/libaio_0.3.111.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch hide | download patch | download mbox

diff --git a/meta/recipes-extended/libaio/libaio_0.3.111.bb b/meta/recipes-extended/libaio/libaio_0.3.111.bb
index 04b50b61ec..8e1cd349a0 100644
--- a/meta/recipes-extended/libaio/libaio_0.3.111.bb
+++ b/meta/recipes-extended/libaio/libaio_0.3.111.bb
@@ -20,4 +20,4 @@  do_install () {
     oe_runmake install DESTDIR=${D}
 }
 
-BBCLASSEXTEND = "nativesdk"
+BBCLASSEXTEND = "native nativesdk"