[RFC,meta-gnome,10/16] dconf-native: add dconf-native recipe

Submitted by brendank310 on Oct. 29, 2018, 4:41 p.m. | Patch ID: 155955

Details

Message ID 4a7b04c4d262dafef02e120102f054f64bb95c69.1540830650.git.brendank310@gmail.com
State Changes Requested
Headers show

Commit Message

brendank310 Oct. 29, 2018, 4:41 p.m.
From: Brendan Kerrigan <kerriganb@ainfosec.com>

gdm recipe requires a native dconf tool.

Signed-off-by: Brendan Kerrigan <kerriganb@ainfosec.com>
---
 .../dconf/dconf-native_0.28.0.bb              | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb

Patch hide | download patch | download mbox

diff --git a/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb b/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
new file mode 100644
index 000000000..ee78fbb66
--- /dev/null
+++ b/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "configuation database system"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+SECTION = "x11/gnome"
+
+SRC_URI[archive.md5sum] = "81faa8e68e5ea71ff0ee75050fc0759c"
+SRC_URI[archive.sha256sum] = "61d3b3865ef58b729c3b39aa0979f886c014aa8362f93dcfc74bf5648ed9c742"
+
+DEPENDS = "dbus glib-2.0 intltool-native"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase gsettings bash-completion vala native
+
+FILES_${PN} += " \
+    ${datadir}/dbus-1 \
+    ${libdir}/gio/modules/*.so \
+    ${bindir}/dconf \
+"

Comments

Ross Burton Oct. 29, 2018, 6:06 p.m.
There's already a dconf in meta-gnome, so just add
BBCLASSEXTEND="native nativesdk".

Ross
On Mon, 29 Oct 2018 at 16:43, brendank310 <brendank310@gmail.com> wrote:
>
> From: Brendan Kerrigan <kerriganb@ainfosec.com>
>
> gdm recipe requires a native dconf tool.
>
> Signed-off-by: Brendan Kerrigan <kerriganb@ainfosec.com>
> ---
>  .../dconf/dconf-native_0.28.0.bb              | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
>  create mode 100644 meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
>
> diff --git a/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb b/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
> new file mode 100644
> index 000000000..ee78fbb66
> --- /dev/null
> +++ b/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
> @@ -0,0 +1,19 @@
> +SUMMARY = "configuation database system"
> +LICENSE = "LGPLv2.1"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
> +SECTION = "x11/gnome"
> +
> +SRC_URI[archive.md5sum] = "81faa8e68e5ea71ff0ee75050fc0759c"
> +SRC_URI[archive.sha256sum] = "61d3b3865ef58b729c3b39aa0979f886c014aa8362f93dcfc74bf5648ed9c742"
> +
> +DEPENDS = "dbus glib-2.0 intltool-native"
> +
> +GNOMEBASEBUILDCLASS = "meson"
> +
> +inherit gnomebase gsettings bash-completion vala native
> +
> +FILES_${PN} += " \
> +    ${datadir}/dbus-1 \
> +    ${libdir}/gio/modules/*.so \
> +    ${bindir}/dconf \
> +"
> --
> 2.17.1
>
> --
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
brendank310 Oct. 29, 2018, 6:27 p.m.
I had initially tried to get the native recipe integrated into it, by
inheriting the native class but was unable to get that to work. Using the
above, I get the following:

ERROR: Required build target 'gdm' has no buildable providers.
Missing or unbuildable dependency chain was: ['gdm', 'dconf-native',
'glib-2.0-utils-native']

Any thoughts on how to resolve this? Should I also be providing a
glib-2.0-utils-native package?

Thanks,
Brendan

On Mon, Oct 29, 2018 at 2:06 PM Burton, Ross <ross.burton@intel.com> wrote:

> There's already a dconf in meta-gnome, so just add
> BBCLASSEXTEND="native nativesdk".
>
> Ross
> On Mon, 29 Oct 2018 at 16:43, brendank310 <brendank310@gmail.com> wrote:
> >
> > From: Brendan Kerrigan <kerriganb@ainfosec.com>
> >
> > gdm recipe requires a native dconf tool.
> >
> > Signed-off-by: Brendan Kerrigan <kerriganb@ainfosec.com>
> > ---
> >  .../dconf/dconf-native_0.28.0.bb              | 19 +++++++++++++++++++
> >  1 file changed, 19 insertions(+)
> >  create mode 100644 meta-gnome/recipes-gnome/dconf/
> dconf-native_0.28.0.bb
> >
> > diff --git a/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
> b/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
> > new file mode 100644
> > index 000000000..ee78fbb66
> > --- /dev/null
> > +++ b/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
> > @@ -0,0 +1,19 @@
> > +SUMMARY = "configuation database system"
> > +LICENSE = "LGPLv2.1"
> > +LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
> > +SECTION = "x11/gnome"
> > +
> > +SRC_URI[archive.md5sum] = "81faa8e68e5ea71ff0ee75050fc0759c"
> > +SRC_URI[archive.sha256sum] =
> "61d3b3865ef58b729c3b39aa0979f886c014aa8362f93dcfc74bf5648ed9c742"
> > +
> > +DEPENDS = "dbus glib-2.0 intltool-native"
> > +
> > +GNOMEBASEBUILDCLASS = "meson"
> > +
> > +inherit gnomebase gsettings bash-completion vala native
> > +
> > +FILES_${PN} += " \
> > +    ${datadir}/dbus-1 \
> > +    ${libdir}/gio/modules/*.so \
> > +    ${bindir}/dconf \
> > +"
> > --
> > 2.17.1
> >
> > --
> > _______________________________________________
> > Openembedded-devel mailing list
> > Openembedded-devel@lists.openembedded.org
> > http://lists.openembedded.org/mailman/listinfo/openembedded-devel
>
Khem Raj Oct. 29, 2018, 7:30 p.m.
On Mon, Oct 29, 2018 at 11:27 AM Brendan Kerrigan <brendank310@gmail.com>
wrote:

> I had initially tried to get the native recipe integrated into it, by
> inheriting the native class but was unable to get that to work. Using the
> above, I get the following:
>
> ERROR: Required build target 'gdm' has no buildable providers.
> Missing or unbuildable dependency chain was: ['gdm', 'dconf-native',
> 'glib-2.0-utils-native']
>
> Any thoughts on how to resolve this? Should I also be providing a
> glib-2.0-utils-native package?
>

Just add that dependency to target only recipe via class-target override
perhaps

>
> Thanks,
> Brendan
>
> On Mon, Oct 29, 2018 at 2:06 PM Burton, Ross <ross.burton@intel.com>
> wrote:
>
> > There's already a dconf in meta-gnome, so just add
> > BBCLASSEXTEND="native nativesdk".
> >
> > Ross
> > On Mon, 29 Oct 2018 at 16:43, brendank310 <brendank310@gmail.com> wrote:
> > >
> > > From: Brendan Kerrigan <kerriganb@ainfosec.com>
> > >
> > > gdm recipe requires a native dconf tool.
> > >
> > > Signed-off-by: Brendan Kerrigan <kerriganb@ainfosec.com>
> > > ---
> > >  .../dconf/dconf-native_0.28.0.bb              | 19
> +++++++++++++++++++
> > >  1 file changed, 19 insertions(+)
> > >  create mode 100644 meta-gnome/recipes-gnome/dconf/
> > dconf-native_0.28.0.bb
> > >
> > > diff --git a/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
> > b/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
> > > new file mode 100644
> > > index 000000000..ee78fbb66
> > > --- /dev/null
> > > +++ b/meta-gnome/recipes-gnome/dconf/dconf-native_0.28.0.bb
> > > @@ -0,0 +1,19 @@
> > > +SUMMARY = "configuation database system"
> > > +LICENSE = "LGPLv2.1"
> > > +LIC_FILES_CHKSUM =
> "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
> > > +SECTION = "x11/gnome"
> > > +
> > > +SRC_URI[archive.md5sum] = "81faa8e68e5ea71ff0ee75050fc0759c"
> > > +SRC_URI[archive.sha256sum] =
> > "61d3b3865ef58b729c3b39aa0979f886c014aa8362f93dcfc74bf5648ed9c742"
> > > +
> > > +DEPENDS = "dbus glib-2.0 intltool-native"
> > > +
> > > +GNOMEBASEBUILDCLASS = "meson"
> > > +
> > > +inherit gnomebase gsettings bash-completion vala native
> > > +
> > > +FILES_${PN} += " \
> > > +    ${datadir}/dbus-1 \
> > > +    ${libdir}/gio/modules/*.so \
> > > +    ${bindir}/dconf \
> > > +"
> > > --
> > > 2.17.1
> > >
> > > --
> > > _______________________________________________
> > > Openembedded-devel mailing list
> > > Openembedded-devel@lists.openembedded.org
> > > http://lists.openembedded.org/mailman/listinfo/openembedded-devel
> >
> --
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
>
Ross Burton Oct. 29, 2018, 9:17 p.m.
On Mon, 29 Oct 2018 at 19:30, Khem Raj <raj.khem@gmail.com> wrote:
>> I had initially tried to get the native recipe integrated into it, by
>> inheriting the native class but was unable to get that to work. Using the
>> above, I get the following:
>>
>> ERROR: Required build target 'gdm' has no buildable providers.
>> Missing or unbuildable dependency chain was: ['gdm', 'dconf-native',
>> 'glib-2.0-utils-native']
>>
>> Any thoughts on how to resolve this? Should I also be providing a
>> glib-2.0-utils-native package?

I'm assuming you meant BBCLASSEXTEND and not an explicit inherit native.

> Just add that dependency to target only recipe via class-target override perhaps

To clarify, the dependency comes from the gsettings.bbclass.  This
dependency should be target-only, so use a class-target override.

Ross