diff mbox series

[2/2] stress-ng: improve makefile use

Message ID 20221107220910.193855-2-ross.burton@arm.com
State New
Headers show
Series [1/2] populate_sdk_ext: use ConfigParser instead of SafeConfigParser | expand

Commit Message

Ross Burton Nov. 7, 2022, 10:09 p.m. UTC
Set VERBOSE=1 so the compile logs are useful, perform the configure in
do_configure, and set bindir correctly.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-extended/stress-ng/stress-ng_0.14.06.bb | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.14.06.bb b/meta/recipes-extended/stress-ng/stress-ng_0.14.06.bb
index 359560b9e24..b4068b0598b 100644
--- a/meta/recipes-extended/stress-ng/stress-ng_0.14.06.bb
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.14.06.bb
@@ -18,12 +18,15 @@  RCONFLICTS:${PN} = "stress"
 
 inherit bash-completion
 
-do_compile:prepend() {
+EXTRA_OEMAKE = "VERBOSE=1"
+
+do_configure() {
     mkdir -p configs
     touch configs/HAVE_APPARMOR
+    oe_runmake makeconfig
 }
 
 do_install() {
-    oe_runmake DESTDIR=${D} install
+    oe_runmake DESTDIR=${D} BINDIR=${bindir} install
     ln -s stress-ng ${D}${bindir}/stress
 }