diff mbox series

[master/kirkstone,20/50] machine: add am62xx-lp-evm configuration

Message ID 20221104224653.1223044-21-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series 2022.10 sync up with Dunfell | expand

Commit Message

Denys Dmytriyenko Nov. 4, 2022, 10:46 p.m. UTC
From: Anand Gadiyar <gadiyar@ti.com>

This platform is similar to the currently supported am62xx-evm, except
that we currently need new defconfigs for u-boot and new dtbs in the
filesystem.

Signed-off-by: Anand Gadiyar <gadiyar@ti.com>
Cc: Hari Nagalla <hnagalla@ti.com>
Cc: Andrew Davis <afd@ti.com>
Cc: Praneeth Bajjuri <praneeth@ti.com>
Cc: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf | 11 +++++++++++
 meta-ti-bsp/conf/machine/am62xx-lp-evm.conf      | 16 ++++++++++++++++
 .../recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb       |  1 +
 .../tifs-lpm-stub/tifs-lpm-stub_git.bb           |  2 +-
 .../recipes-kernel/linux/kernel-rdepends.inc     |  3 +--
 5 files changed, 30 insertions(+), 3 deletions(-)
 create mode 100644 meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf
 create mode 100644 meta-ti-bsp/conf/machine/am62xx-lp-evm.conf
diff mbox series

Patch

diff --git a/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf b/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf
new file mode 100644
index 00000000..ca4ced5a
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5.conf
@@ -0,0 +1,11 @@ 
+#@TYPE: Machine
+#@NAME: AM62XX LP EVM (R5F)
+#@DESCRIPTION: Machine configuration for the TI AM62xx LP EVM (R5F core)
+
+require conf/machine/include/k3r5.inc
+
+SYSFW_SOC = "am62x"
+SYSFW_CONFIG = "evm"
+SYSFW_SUFFIX = "gp"
+
+UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
diff --git a/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf b/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf
new file mode 100644
index 00000000..ef8e8692
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf
@@ -0,0 +1,16 @@ 
+#@TYPE: Machine
+#@NAME: AM62XX LP EVM
+#@DESCRIPTION: Machine configuration for the TI AM62XX LP EVM
+
+require conf/machine/include/am62xx.inc
+
+MACHINE_FEATURES += "gpu"
+
+KERNEL_DEVICETREE = " \
+    ti/k3-am62x-lp-sk.dtb \
+    ti/k3-am625-skeleton.dtb \
+    ti/k3-am625-sk-lpmdemo.dtb \
+    ti/k3-am625-sk-csi2-ov5640.dtbo \
+"
+
+UBOOT_MACHINE = "am62x_lpsk_a53_defconfig"
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 1b0dc4a1..6484ae87 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -36,6 +36,7 @@  SYSFW_PREFIX:j7200-hs-evm-k3r5 = "fs"
 SYSFW_PREFIX:j721s2-evm-k3r5 = "fs"
 SYSFW_PREFIX:j721s2-hs-evm-k3r5 = "fs"
 SYSFW_PREFIX:am62xx-evm-k3r5 = "fs"
+SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs"
 
 SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"
 
diff --git a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
index 90af55f1..ce5f4e1f 100644
--- a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
+++ b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
@@ -7,7 +7,7 @@  PR = "${INC_PR}.0"
 
 CLEANBROKEN = "1"
 
-COMPATIBLE_MACHINE = "am62xx-evm"
+COMPATIBLE_MACHINE = "am62xx"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index 1071a278..3da41581 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -30,5 +30,4 @@  RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7 = " vxd-dec-fw"
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw"
 
 # Add run-time dependency for TIFS Low Power Module stub
-RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx-evm = " tifs-lpm-stub"
-
+RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx = " tifs-lpm-stub"