diff mbox series

[master/kirkstone,08/50] ti-sci-fw: Only deploy the raw SYSFW images for one machine target

Message ID 20221104224653.1223044-9-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series 2022.10 sync up with Dunfell | expand

Commit Message

Denys Dmytriyenko Nov. 4, 2022, 10:46 p.m. UTC
From: Andrew Davis <afd@ti.com>

This recipe deploys the raw SYSFW unconditionally which causes issues
when doing multiconfig builds. What should happen is only one deploys
these, select that the same way we select which one deploys the default
SYSFW symlink. Move the deploy step there.

Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 506052ca..ae90e877 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -99,6 +99,7 @@  do_deploy () {
 		ln -sf ${SYSFW_VBINARY} ${DEPLOYDIR}/${SYSFW_IMAGE}
 		if [ ! -z "${SYSFW_SYMLINK}" ]; then
 			ln -sf ${SYSFW_VBINARY} ${DEPLOYDIR}/${SYSFW_SYMLINK}
+			install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
 		fi
 	fi
 
@@ -106,10 +107,9 @@  do_deploy () {
 		install -m 644 ${WORKDIR}/imggen/${SYSFW_TIBOOT3} ${DEPLOYDIR}/${SYSFW_TIBOOT3}
 		if [ ! -z "${SYSFW_TIBOOT3_SYMLINK}" ]; then
 			ln -sf ${SYSFW_TIBOOT3} ${DEPLOYDIR}/${SYSFW_TIBOOT3_SYMLINK}
+			install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
 		fi
 	fi
-
-	install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
 }
 
 addtask deploy before do_build after do_compile