diff mbox series

[master/kirkstone,08/14] meta-arago: Use new J7 SoC names over specific board names

Message ID 20221104214112.1221365-9-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series 2022.10 sync up with Dunfell | expand

Commit Message

Denys Dmytriyenko Nov. 4, 2022, 9:41 p.m. UTC
From: Andrew Davis <afd@ti.com>

Now that we have SoC names, we can avoid adding features based on the
board name. We expect folks to create their own boards based on these
SoCs, and so using the TI made EVM board name everywhere adds extra churn
when adding a new board. Plus it is more correct for most of these
features as they depend on the SoC, not on the EVM board.

One other thing we do here is to not use the generic "j7" name,
the current and future J7 devices are far to feature diverse
to group at this level. Grouping like that will lead to the wrong
things getting enabled as new J7 SoCs are added.

Signed-off-by: Andrew Davis <afd@ti.com>
Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb  | 3 +--
 meta-arago-distro/recipes-core/images/tisdk-core-bundle.inc | 4 +++-
 meta-arago-distro/recipes-core/packagegroups/ti-test.bb     | 2 +-
 .../gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend      | 6 +-----
 4 files changed, 6 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb b/meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb
index ec4e0344..b49548a6 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb
@@ -12,8 +12,7 @@  DEPLOY_SPL_NAME:k3 = "tispl.bin tiboot3.bin"
 
 DEPLOY_IMAGES_NAME:k3 = "bl31.bin bl32.bin"
 DEPLOY_IMAGES_NAME:append:am65xx = " sysfw.itb"
-DEPLOY_IMAGES_NAME:append:j721e-evm = " sysfw.itb"
-DEPLOY_IMAGES_NAME:append:j721e-hs-evm = " sysfw.itb"
+DEPLOY_IMAGES_NAME:append:j721e = " sysfw.itb"
 DEPLOY_IMAGES_NAME:append:am65xx-evm = " sysfw-am65x-evm.itb sysfw-am65x_sr2-evm.itb"
 
 ARAGO_TISDK_IMAGE ?= "tisdk-core-bundle"
diff --git a/meta-arago-distro/recipes-core/images/tisdk-core-bundle.inc b/meta-arago-distro/recipes-core/images/tisdk-core-bundle.inc
index 90b5ccef..9da4b0d0 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-core-bundle.inc
+++ b/meta-arago-distro/recipes-core/images/tisdk-core-bundle.inc
@@ -24,7 +24,9 @@  DTB_FILTER:am57xx-hs-evm = "${DTB_FILTER:am57xx-evm}"
 DTB_FILTER:ti43x = "am43"
 DTB_FILTER:omapl138 = "da850"
 DTB_FILTER:am65xx = "am65"
-DTB_FILTER:j7 = "j721e"
+DTB_FILTER:j721e = "j721e"
+DTB_FILTER:j7200 = "j7200"
+DTB_FILTER:j721s2 = "j721s2"
 
 # List of target side images to build for the SDK
 TARGET_IMAGES = "tisdk-base-image tisdk-default-image tisdk-thinlinux-image tisdk-bootstrap-image"
diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
index 99a6cc82..ca4e254e 100644
--- a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
@@ -78,7 +78,7 @@  ARAGO_TI_TEST:append:k3 = " \
     k3conf \
 "
 
-ARAGO_TI_TEST:append:j7 = " \
+ARAGO_TI_TEST:append:j721e = " \
     ufs-utils \
 "
 
diff --git a/meta-arago-extras/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend b/meta-arago-extras/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
index de9f1c7d..5cc57460 100644
--- a/meta-arago-extras/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
+++ b/meta-arago-extras/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
@@ -28,11 +28,7 @@  SRC_URI:append:am65xx = " \
     ${GSTDRM_WAYLANDSINK_PATCHES} \
 "
 
-SRC_URI:append:j721e-evm = " \
-    ${GSTDRM_WAYLANDSINK_PATCHES} \
-"
-
-SRC_URI:append:j721e-hs-evm = " \
+SRC_URI:append:j721e = " \
     ${GSTDRM_WAYLANDSINK_PATCHES} \
 "