diff mbox series

[dunfell,2/2] ti-sci-fw: use getVar() to check if TI_SECURE_DEV_PKG_K3 is defined

Message ID 1667427383-18305-3-git-send-email-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Fix K3 HS builds when external SECDEV is not provided | expand

Commit Message

Denys Dmytriyenko Nov. 2, 2022, 10:16 p.m. UTC
From: Denys Dmytriyenko <denys@konsulko.com>

Otherwise undefined variable is returned literally as ${TI_SECURE_DEV_PKG_K3}
and the condition won't work.

Cc: Andrew Davis <afd@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Andrew Davis Nov. 3, 2022, 1:32 a.m. UTC | #1
On 11/2/22 5:16 PM, Denys Dmytriyenko wrote:
> From: Denys Dmytriyenko <denys@konsulko.com>
> 
> Otherwise undefined variable is returned literally as ${TI_SECURE_DEV_PKG_K3}
> and the condition won't work.
> 
> Cc: Andrew Davis <afd@ti.com>
> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
> ---
>   recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> index 866cd7b..e5dcdd6 100644
> --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
> @@ -20,7 +20,7 @@ COMPATIBLE_MACHINE_aarch64 = "null"
>   
>   PACKAGE_ARCH = "${MACHINE_ARCH}"
>   
> -TI_SECURE_DEV_PKG = "${@ '${TI_SECURE_DEV_PKG_K3}' or '${TI_K3_SECDEV_INSTALL_DIR}' }"
> +TI_SECURE_DEV_PKG = "${@ d.getVar('TI_SECURE_DEV_PKG_K3') or '${TI_K3_SECDEV_INSTALL_DIR}' }"
>   export TI_SECURE_DEV_PKG
>   

I remember +Randolph did exactly this in another spot in this same file[0].
Should we check this everywhere we have input env vars?

Acked-by: Andrew Davis <afd@ti.com>

[0] https://patchwork.yoctoproject.org/project/ti/patch/20220902201247.605908-1-rs@ti.com/


>   SYSFW_SOC ?= "unknown"
diff mbox series

Patch

diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 866cd7b..e5dcdd6 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -20,7 +20,7 @@  COMPATIBLE_MACHINE_aarch64 = "null"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-TI_SECURE_DEV_PKG = "${@ '${TI_SECURE_DEV_PKG_K3}' or '${TI_K3_SECDEV_INSTALL_DIR}' }"
+TI_SECURE_DEV_PKG = "${@ d.getVar('TI_SECURE_DEV_PKG_K3') or '${TI_K3_SECDEV_INSTALL_DIR}' }"
 export TI_SECURE_DEV_PKG
 
 SYSFW_SOC ?= "unknown"