diff mbox series

[meta-openembedded,PATCHv2] spice-gtk: add recipe

Message ID 20221031065035.2308617-1-f_l_k@t-online.de
State New
Headers show
Series [meta-openembedded,PATCHv2] spice-gtk: add recipe | expand

Commit Message

Markus Volk Oct. 31, 2022, 6:50 a.m. UTC
Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../recipes-support/spice/spice-gtk_0.4.1.bb  | 43 +++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb

Comments

Fabio Estevam Dec. 7, 2022, 5:39 p.m. UTC | #1
Hi Markus,

On Mon, Oct 31, 2022 at 3:50 AM Markus Volk <f_l_k@t-online.de> wrote:
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  .../recipes-support/spice/spice-gtk_0.4.1.bb  | 43 +++++++++++++++++++
>  1 file changed, 43 insertions(+)
>  create mode 100644 meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
>
> diff --git a/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
> new file mode 100644
> index 000000000..58089c0a2
> --- /dev/null
> +++ b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
> @@ -0,0 +1,43 @@
> +SUMMARY = "A Gtk client and libraries for SPICE remote desktop servers."
> +HOMEPAGE = "https://spice-space.org"
> +LICENSE = "LGPL-2.1-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"

spice-gtk uses two subprojects: keycodemapdb and spice-common.

keycodemapdb has the following licenses:

 - GNU General Public License (version 2 or later)
- 3-clause BSD License

Shouldn't this be reflected in the LICENSE line?
Markus Volk Dec. 7, 2022, 5:54 p.m. UTC | #2
Am Mi, 7. Dez 2022 um 14:39:47 -0300 schrieb Fabio Estevam 
<festevam@gmail.com>:
> Shouldn't this be reflected in the LICENSE line

Sent a patch for it
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
new file mode 100644
index 000000000..58089c0a2
--- /dev/null
+++ b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
@@ -0,0 +1,43 @@ 
+SUMMARY = "A Gtk client and libraries for SPICE remote desktop servers."
+HOMEPAGE = "https://spice-space.org"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRCREV = "74e673d7c3d9cd281d85c691fbc520107066da01"
+
+SRC_URI = "gitsm://gitlab.freedesktop.org/spice/spice-gtk.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = " \
+	${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
+	${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland wayland-native wayland-protocols', '', d)} \
+	acl \
+	cyrus-sasl \
+	gstreamer1.0 \
+	gstreamer1.0-plugins-base \
+	gstreamer1.0-vaapi \
+	gtk+3 \
+	jpeg \
+	json-glib \
+	libcap-ng \
+	libepoxy \
+	libopus \
+	libusb1 \
+	lz4 \
+	pixman \
+	python3-pyparsing-native \
+	python3-six-native \
+	spice-protocol \
+	usbredir \
+	usbutils \
+	zlib \
+"
+
+RDEPENDS:${PN} = "python3-pyparsing python3-six"
+
+inherit meson pkgconfig vala gobject-introspection
+
+EXTRA_OEMESON = "-Dpie=true -Dvapi=enabled -Dintrospection=enabled"
+
+FILES:${PN} += "${datadir}"