python3-more-itertools: upgrade 8.10.0 -> 8.11.0

Message ID 1636988654-78792-2-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 7767810424a79c9cb60b4ea763bc1c10efe0b73b
Headers show
Series python3-more-itertools: upgrade 8.10.0 -> 8.11.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 15, 2021, 3:04 p.m. UTC
8.11.0:
New functions
The :func:`before_and_after`, :func:`sliding_window`, and :func:`triplewise` recipes from the Python 3.10 docs were added
:func:`duplicates_everseen` and :func:`duplicates_justseen` (thanks to OrBin and DavidPratt512)
:func:`minmax` (thanks to Ricocotam, MSeifert04, and ruancomelli)
:func:`strictly_n` (thanks to hwalinga and NotWearingPants)
:func:`unique_in_window`
Changes to existing functions
:func:`groupby_transform` had its type stub improved (thanks to mjk4 and ruancomelli)
:func:`is_sorted` now accepts a strict parameter (thanks to Dutcho and ruancomelli)
:func:`zip_broadcast` was updated to fix a bug (thanks to kalekundert)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ore-itertools_8.10.0.bb => python3-more-itertools_8.11.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-more-itertools_8.10.0.bb => python3-more-itertools_8.11.0.bb} (86%)

Patch

diff --git a/meta/recipes-devtools/python/python3-more-itertools_8.10.0.bb b/meta/recipes-devtools/python/python3-more-itertools_8.11.0.bb
similarity index 86%
rename from meta/recipes-devtools/python/python3-more-itertools_8.10.0.bb
rename to meta/recipes-devtools/python/python3-more-itertools_8.11.0.bb
index 93d3ad60f8..a18bb4d667 100644
--- a/meta/recipes-devtools/python/python3-more-itertools_8.10.0.bb
+++ b/meta/recipes-devtools/python/python3-more-itertools_8.11.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/erikrose/more-itertools"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
 
-SRC_URI[sha256sum] = "1debcabeb1df793814859d64a81ad7cb10504c24349368ccf214c664c474f41f"
+SRC_URI[sha256sum] = "0a2fd25d343c08d7e7212071820e7e7ea2f41d8fb45d6bc8a00cd6ce3b7aab88"
 
 inherit pypi setuptools3 ptest