diff mbox series

[meta-python] python3-charset-normalizer: upgrade 2.1.1 -> 3.0.0

Message ID 1666593696-28739-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python] python3-charset-normalizer: upgrade 2.1.1 -> 3.0.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Oct. 24, 2022, 6:41 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
Added

    Extend the capability of explain=True when cp_isolation contains at most two entries (min one), will log in details of the Mess-detector results
    Support for alternative language frequency set in charset_normalizer.assets.FREQUENCIES
    Add parameter language_threshold in from_bytes, from_path and from_fp to adjust the minimum expected coherence ratio
    normalizer --version now specify if current version provide extra speedup (meaning mypyc compilation whl)

Changed

    Build with static metadata using 'build' frontend
    Make the language detection stricter
    Optional: Module md.py can be compiled using Mypyc to provide an extra speedup up to 4x faster than v2.1

Fixed

    CLI with opt --normalize fail when using full path for files
    TooManyAccentuatedPlugin induce false positive on the mess detection when too few alpha character have been fed to it
    Sphinx warnings when generating the documentation

Removed

    Coherence detector no longer return 'Simple English' instead return 'English'
    Coherence detector no longer return 'Classical Chinese' instead return 'Chinese'
    Breaking: Method first() and best() from CharsetMatch
    UTF-7 will no longer appear as "detected" without a recognized SIG/mark (is unreliable/conflict with ASCII)
    Breaking: Class aliases CharsetDetector, CharsetDoctor, CharsetNormalizerMatch and CharsetNormalizerMatches
    Breaking: Top-level function normalize
    Breaking: Properties chaos_secondary_pass, coherence_non_latin and w_counter from CharsetMatch
    Support for the backport unicodedata2


Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...-normalizer_2.1.1.bb => python3-charset-normalizer_3.0.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-charset-normalizer_2.1.1.bb => python3-charset-normalizer_3.0.0.bb} (82%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-charset-normalizer_2.1.1.bb b/meta-python/recipes-devtools/python/python3-charset-normalizer_3.0.0.bb
similarity index 82%
rename from meta-python/recipes-devtools/python/python3-charset-normalizer_2.1.1.bb
rename to meta-python/recipes-devtools/python/python3-charset-normalizer_3.0.0.bb
index 1ab72e53d1..895f88a62e 100644
--- a/meta-python/recipes-devtools/python/python3-charset-normalizer_2.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-charset-normalizer_3.0.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/ousret/charset_normalizer"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=0974a390827087287db39928f7c524b5"
 
-SRC_URI[sha256sum] = "5a3d016c7c547f69d6f81fb0db9449ce888b418b5b9952cc5e6e66843e9dd845"
+SRC_URI[sha256sum] = "b27d10ad15740b45fd55f76e6901a4391e6dca3917ef48ecdcf17edf6e00d770"
 
 inherit pypi setuptools3