dhcp-relay: fix rebuilds

Message ID 20211213124614.3862310-1-ross.burton@arm.com
State New
Headers show
Series dhcp-relay: fix rebuilds | expand

Commit Message

Ross Burton Dec. 13, 2021, 12:46 p.m. UTC
dhcp-relay needs a fresh tarball of bind unpacked in ${S}, but this is
done by fetching the tarball to ${WORKDIR}, then in do_configure moving
it to ${S} and unpacking it.

If dhcp-relay is re-configured, the tarball no longer exists in ${WORKDIR}
so this fails.  Copy instead of moving so rebuilds work.

Also don't rename the downloaded file to just bind.tar.gz as that can
cause probems if the version changes.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb         | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Patch

diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
index 8e41609f00..c86926813d 100644
--- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
+++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
@@ -11,7 +11,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;md5=004a4db50a1e20972e924a8618747
 DEPENDS = "openssl libcap zlib"
 
 SRC_URI = "https://ftp.isc.org/isc/dhcp/4.4.2-P1/dhcp-4.4.2-P1.tar.gz \
-           https://ftp.isc.org/isc/bind9/9.11.32/bind-9.11.32.tar.gz;name=bind;downloadfilename=bind.tar.gz;unpack=0 \
+           https://ftp.isc.org/isc/bind9/9.11.32/bind-9.11.32.tar.gz;name=bind;unpack=0 \
            file://default-relay \
            file://init-relay \
            file://dhcrelay.service \
@@ -47,11 +47,11 @@  EXTRA_OECONF = "--enable-paranoia \
 # Enable shared libs per dhcp README
 do_configure:prepend () {
     cp configure.ac+lt configure.ac
-    rm ${S}/bind/bind.tar.gz
-    mv ${WORKDIR}/bind.tar.gz ${S}/bind/
+    cp ${WORKDIR}/bind-9.11.32.tar.gz ${S}/bind/bind.tar.gz
 }
 
 do_compile:prepend() {
+    # Need to unpack this now instead of earlier as do_configure will delete the configure script
     rm -rf ${S}/bind/bind-9.11.32/
     tar xf ${S}/bind/bind.tar.gz -C ${S}/bind
     install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.32/