diff mbox series

perf: Depend on native setuptools3

Message ID 20221011030216.3874881-1-raj.khem@gmail.com
State Accepted, archived
Commit da3d00178809bbf7cc453401e0c5937796ebc2c1
Headers show
Series perf: Depend on native setuptools3 | expand

Commit Message

Khem Raj Oct. 11, 2022, 3:02 a.m. UTC
perf has need for python setuptools when scripting is enabled
from 6.0.0 onwards it seems to throw an explicit error

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/perf/perf.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Bruce Ashfield Oct. 11, 2022, 11:53 a.m. UTC | #1
There's already several versions of this patch floating around.

There was an error on the AB with the latest version of it that neither
Ross or myself could reproduce so we are looking at that part of it now.

Cheers,

Bruce

On Mon, Oct 10, 2022 at 11:02 PM Khem Raj <raj.khem@gmail.com> wrote:

> perf has need for python setuptools when scripting is enabled
> from 6.0.0 onwards it seems to throw an explicit error
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
>  meta/recipes-kernel/perf/perf.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/
> perf.bb
> index 31bc04635d..c1b0bd22d8 100644
> --- a/meta/recipes-kernel/perf/perf.bb
> +++ b/meta/recipes-kernel/perf/perf.bb
> @@ -13,7 +13,7 @@ PR = "r9"
>
>  PACKAGECONFIG ??= "scripting tui libunwind"
>  PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
> -PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3"
> +PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3
> python3-setuptools-native"
>  # gui support was added with kernel 3.6.35
>  # since 3.10 libnewt was replaced by slang
>  # to cover a wide range of kernel we add both dependencies
> --
> 2.38.0
>
>
Fabio Estevam Nov. 1, 2022, 5:11 p.m. UTC | #2
Hi Armin,

On Tue, Oct 11, 2022 at 12:02 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> perf has need for python setuptools when scripting is enabled
> from 6.0.0 onwards it seems to throw an explicit error
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>

This one landed in master:
https://github.com/openembedded/openembedded-core/commit/da3d00178809bbf7cc453401e0c5937796ebc2c1

Could it be backported to kirkstone too?

I am facing an error when building a 6.0 kernel and this commit in
master fixes it.

Thanks
Khem Raj Nov. 1, 2022, 5:21 p.m. UTC | #3
On 11/1/22 10:11 AM, Fabio Estevam wrote:
> Hi Armin,
> 
> On Tue, Oct 11, 2022 at 12:02 AM Khem Raj <raj.khem@gmail.com> wrote:
>>
>> perf has need for python setuptools when scripting is enabled
>> from 6.0.0 onwards it seems to throw an explicit error
>>
>> Signed-off-by: Khem Raj <raj.khem@gmail.com>
>> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> 
> This one landed in master:
> https://github.com/openembedded/openembedded-core/commit/da3d00178809bbf7cc453401e0c5937796ebc2c1
> 
> Could it be backported to kirkstone too?
> 
> I am facing an error when building a 6.0 kernel and this commit in
> master fixes it.
> 
> Thanks

+Steve
Steve Sakoman Nov. 1, 2022, 5:30 p.m. UTC | #4
On Tue, Nov 1, 2022 at 7:21 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> On 11/1/22 10:11 AM, Fabio Estevam wrote:
> > Hi Armin,
> >
> > On Tue, Oct 11, 2022 at 12:02 AM Khem Raj <raj.khem@gmail.com> wrote:
> >>
> >> perf has need for python setuptools when scripting is enabled
> >> from 6.0.0 onwards it seems to throw an explicit error
> >>
> >> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> >> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> >
> > This one landed in master:
> > https://github.com/openembedded/openembedded-core/commit/da3d00178809bbf7cc453401e0c5937796ebc2c1
> >
> > Could it be backported to kirkstone too?
> >
> > I am facing an error when building a 6.0 kernel and this commit in
> > master fixes it.
> >
> > Thanks
>
> +Steve

Got it!

Steve
diff mbox series

Patch

diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 31bc04635d..c1b0bd22d8 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -13,7 +13,7 @@  PR = "r9"
 
 PACKAGECONFIG ??= "scripting tui libunwind"
 PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
-PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3"
+PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3 python3-setuptools-native"
 # gui support was added with kernel 3.6.35
 # since 3.10 libnewt was replaced by slang
 # to cover a wide range of kernel we add both dependencies