[meta-oe] soci: update to 4.0.2

Message ID 20211211145254.3385758-1-open.source@oleksandr-kravchuk.com
State New
Headers show
Series [meta-oe] soci: update to 4.0.2 | expand

Commit Message

Oleksandr Kravchuk Dec. 11, 2021, 2:52 p.m. UTC
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
---
 ...hen-SIGSTKSZ-is-no-longer-a-constant.patch | 42 +++++++++++++++++++
 .../soci/{soci_3.2.3.bb => soci_4.0.2.bb}     | 11 ++---
 2 files changed, 45 insertions(+), 8 deletions(-)
 create mode 100644 meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch
 rename meta-oe/recipes-dbs/soci/{soci_3.2.3.bb => soci_4.0.2.bb} (84%)

Patch

diff --git a/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch b/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch
new file mode 100644
index 000000000..8e32ebb0b
--- /dev/null
+++ b/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch
@@ -0,0 +1,42 @@ 
+From fae154eb209e068586e1adb589de5d273fcf4b4f Mon Sep 17 00:00:00 2001
+From: Denis Arnaud <denis.arnaud_fedora@m4x.org>
+Date: Tue, 18 May 2021 00:05:03 +0200
+Subject: [PATCH] Fix build when SIGSTKSZ is no longer a constant
+
+In the latest glibc versions SIGSTKSZ is not a constant any more, which
+broke building the tests with it.
+
+Work around this by hard-coding a typical value for it.
+
+closes #886.
+
+Upstream-Status: Backport.
+---
+ tests/catch.hpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/catch.hpp b/tests/catch.hpp
+index 014df2c5..85067813 100644
+--- a/tests/catch.hpp
++++ b/tests/catch.hpp
+@@ -6489,7 +6489,7 @@ namespace Catch {
+         static bool isSet;
+         static struct sigaction oldSigActions [sizeof(signalDefs)/sizeof(SignalDefs)];
+         static stack_t oldSigStack;
+-        static char altStackMem[SIGSTKSZ];
++        static char altStackMem[8192];
+ 
+         static void handleSignal( int sig ) {
+             std::string name = "<unknown signal>";
+@@ -6540,7 +6540,7 @@ namespace Catch {
+     bool FatalConditionHandler::isSet = false;
+     struct sigaction FatalConditionHandler::oldSigActions[sizeof(signalDefs)/sizeof(SignalDefs)] = {};
+     stack_t FatalConditionHandler::oldSigStack = {};
+-    char FatalConditionHandler::altStackMem[SIGSTKSZ] = {};
++    char FatalConditionHandler::altStackMem[8192] = {};
+ 
+ } // namespace Catch
+ 
+-- 
+2.25.1
+
diff --git a/meta-oe/recipes-dbs/soci/soci_3.2.3.bb b/meta-oe/recipes-dbs/soci/soci_4.0.2.bb
similarity index 84%
rename from meta-oe/recipes-dbs/soci/soci_3.2.3.bb
rename to meta-oe/recipes-dbs/soci/soci_4.0.2.bb
index c218b7151..fb67e0c54 100644
--- a/meta-oe/recipes-dbs/soci/soci_3.2.3.bb
+++ b/meta-oe/recipes-dbs/soci/soci_4.0.2.bb
@@ -1,6 +1,3 @@ 
-# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
-# Released under the MIT license (see COPYING.MIT for the terms)
-
 DESCRIPTION = "The C++ Database Access Library"
 HOMEPAGE = "http://soci.sourceforge.net"
 LICENSE = "BSL-1.0"
@@ -8,12 +5,9 @@  LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
 SECTION = "libs"
 DEPENDS = "boost"
 
-
 SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz \
-           file://soci_libdir.patch \
-          "
-SRC_URI[md5sum] = "acfbccf176cd20e06833a8037a2d3699"
-SRC_URI[sha256sum] = "2c659db0f4f7b424bbcffe195c03c293a1dbf676189a27b077fb2aab4d53a610"
+           file://0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch"
+SRC_URI[sha256sum] = "34da2d2320539463da8a5131253246fa2671e0438ab5fd1e5119edb428f558a5"
 
 TESTCONFIG = '-DSOCI_TEST_EMPTY_CONNSTR="dummy" -DSOCI_TEST_SQLITE3_CONNSTR="test.db" \
               -DSOCI_TEST_POSTGRESQL_CONNSTR:STRING="dbname=soci_test" \
@@ -29,6 +23,7 @@  PACKAGECONFIG[postgresql] = "-DSOCI_POSTGRESQL=ON,-DSOCI_POSTGRESQL=OFF,postgres
 PACKAGECONFIG[odbc] = "-DSOCI_ODBC=ON,-DSOCI_ODBC=OFF,,"
 PACKAGECONFIG[empty] = "-DSOCI_EMPTY=ON,-DSOCI_EMPTY=OFF,,"
 PACKAGECONFIG[oracle] = "-DWITH_ORACLE=ON --with-oracle-include=${OINCDIR} --with-oracle-lib=${OLIBDIR},-DWITH_ORACLE=OFF,,"
+PACKAGECONFIG[firebird] = "-DWITH_FIREBIRD=ON,-DWITH_FIREBIRD=OFF,,"
 PACKAGECONFIG[ptest] = "${TESTCONFIG},,,"
 
 # enable your backend by default we enable 'empty'