diff mbox series

dbus: Fix incorrect path for container sockets

Message ID 20221006210210.1744501-1-sean.anderson@seco.com
State New
Headers show
Series dbus: Fix incorrect path for container sockets | expand

Commit Message

Sean Anderson Oct. 6, 2022, 9:02 p.m. UTC
I noticed the following warning from systemd-tmpfiles while booting:

    /usr/lib/tmpfiles.d/dbus.conf:13: Line references path below legacy directory /var/run/, updating /var/run/dbus/containers

The offending line [1] is

    d @EXPANDED_RUNSTATEDIR@/dbus/containers 0755 @DBUS_USER@ - - -

We do not set runstatedir, so it defaults to /var/run. Set runstatedir
to /run to avoid this problem.

[1] https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/bus/tmpfiles.d/dbus.conf.in#L13

Fixes: 4df1a16e5c ("dbus: Specify runstatedir configure option")
Signed-off-by: Sean Anderson <sean.anderson@seco.com>
---

 meta/recipes-core/dbus/dbus_1.14.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Sean Anderson Oct. 6, 2022, 9:03 p.m. UTC | #1
On 10/6/22 5:02 PM, Sean Anderson wrote:
> I noticed the following warning from systemd-tmpfiles while booting:
> 
>     /usr/lib/tmpfiles.d/dbus.conf:13: Line references path below legacy directory /var/run/, updating /var/run/dbus/containers
> 
> The offending line [1] is
> 
>     d @EXPANDED_RUNSTATEDIR@/dbus/containers 0755 @DBUS_USER@ - - -
> 
> We do not set runstatedir, so it defaults to /var/run. Set runstatedir
> to /run to avoid this problem.
> 
> [1] https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/bus/tmpfiles.d/dbus.conf.in#L13
> 
> Fixes: 4df1a16e5c ("dbus: Specify runstatedir configure option")
> Signed-off-by: Sean Anderson <sean.anderson@seco.com>
> ---
> 
>  meta/recipes-core/dbus/dbus_1.14.0.bb | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/meta/recipes-core/dbus/dbus_1.14.0.bb b/meta/recipes-core/dbus/dbus_1.14.0.bb
> index 0046b9fda2..9fb1f777bd 100644
> --- a/meta/recipes-core/dbus/dbus_1.14.0.bb
> +++ b/meta/recipes-core/dbus/dbus_1.14.0.bb
> @@ -21,6 +21,7 @@ EXTRA_OECONF = "--disable-xml-docs \
>                  --disable-doxygen-docs \
>                  --enable-largefile \
>                  --with-system-socket=/run/dbus/system_bus_socket \
> +                --runstatedir=/run \
>                  --enable-tests \
>                  --enable-checks \
>                  --enable-asserts \
> 

oops, ignore this please

I didn't read the patch I put in fixes >.>
Michael Opdenacker Oct. 7, 2022, 7:23 a.m. UTC | #2
Hi Sean

On 06.10.22 23:03, Sean Anderson via lists.openembedded.org wrote:
>
> On 10/6/22 5:02 PM, Sean Anderson wrote:
>> I noticed the following warning from systemd-tmpfiles while booting:
>>
>>      /usr/lib/tmpfiles.d/dbus.conf:13: Line references path below legacy directory /var/run/, updating /var/run/dbus/containers
>>
>> The offending line [1] is
>>
>>      d @EXPANDED_RUNSTATEDIR@/dbus/containers 0755 @DBUS_USER@ - - -
>>
>> We do not set runstatedir, so it defaults to /var/run. Set runstatedir
>> to /run to avoid this problem.
>>
>> [1] https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/bus/tmpfiles.d/dbus.conf.in#L13
>>
>> Fixes: 4df1a16e5c ("dbus: Specify runstatedir configure option")
>> Signed-off-by: Sean Anderson <sean.anderson@seco.com>
>> ---
>>
>>   meta/recipes-core/dbus/dbus_1.14.0.bb | 1 +
>>   1 file changed, 1 insertion(+)
>>
>> diff --git a/meta/recipes-core/dbus/dbus_1.14.0.bb b/meta/recipes-core/dbus/dbus_1.14.0.bb
>> index 0046b9fda2..9fb1f777bd 100644
>> --- a/meta/recipes-core/dbus/dbus_1.14.0.bb
>> +++ b/meta/recipes-core/dbus/dbus_1.14.0.bb
>> @@ -21,6 +21,7 @@ EXTRA_OECONF = "--disable-xml-docs \
>>                   --disable-doxygen-docs \
>>                   --enable-largefile \
>>                   --with-system-socket=/run/dbus/system_bus_socket \
>> +                --runstatedir=/run \
>>                   --enable-tests \
>>                   --enable-checks \
>>                   --enable-asserts \
>>
> oops, ignore this please
>
> I didn't read the patch I put in fixes >.>


There's also a problem with the way you send your patches. I used to 
have it too.

If I apply your patch through "git am", the author of the commit is:
Sean Anderson via lists.openembedded.org 
<sean.anderson=seco.com@lists.openembedded.org>
instead of
Sean Anderson <sean.anderson@seco.com>

Because of this issue, the maintainer has to manually fix this field 
when accepting your patch. Worse, if he doesn't catch this, that's 
harder to fix afterwards.

You should be able to fix this by running:

git config --global sendemail.from "sean.anderson@seco.com"

At least this worked for me. See 
https://www.openembedded.org/wiki/How_to_submit_a_patch_to_OpenEmbedded#Sending_using_git-send-email

Don't hesitate to send a test e-mail to me first if you wish.

Thanks in advance
Michael.
Sean Anderson Oct. 7, 2022, 3:20 p.m. UTC | #3
On 10/7/22 3:23 AM, Michael Opdenacker wrote:
> [You don't often get email from michael.opdenacker@bootlin.com. Learn why this is important at https://aka.ms/LearnAboutSenderIdentification ]
> 
> Hi Sean
> 
> On 06.10.22 23:03, Sean Anderson via lists.openembedded.org wrote:
>>
>> On 10/6/22 5:02 PM, Sean Anderson wrote:
>>> I noticed the following warning from systemd-tmpfiles while booting:
>>>
>>>      /usr/lib/tmpfiles.d/dbus.conf:13: Line references path below legacy directory /var/run/, updating /var/run/dbus/containers
>>>
>>> The offending line [1] is
>>>
>>>      d @EXPANDED_RUNSTATEDIR@/dbus/containers 0755 @DBUS_USER@ - - -
>>>
>>> We do not set runstatedir, so it defaults to /var/run. Set runstatedir
>>> to /run to avoid this problem.
>>>
>>> [1] https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/bus/tmpfiles.d/dbus.conf.in#L13
>>>
>>> Fixes: 4df1a16e5c ("dbus: Specify runstatedir configure option")
>>> Signed-off-by: Sean Anderson <sean.anderson@seco.com>
>>> ---
>>>
>>>   meta/recipes-core/dbus/dbus_1.14.0.bb | 1 +
>>>   1 file changed, 1 insertion(+)
>>>
>>> diff --git a/meta/recipes-core/dbus/dbus_1.14.0.bb b/meta/recipes-core/dbus/dbus_1.14.0.bb
>>> index 0046b9fda2..9fb1f777bd 100644
>>> --- a/meta/recipes-core/dbus/dbus_1.14.0.bb
>>> +++ b/meta/recipes-core/dbus/dbus_1.14.0.bb
>>> @@ -21,6 +21,7 @@ EXTRA_OECONF = "--disable-xml-docs \
>>>                   --disable-doxygen-docs \
>>>                   --enable-largefile \
>>>                   --with-system-socket=/run/dbus/system_bus_socket \
>>> +                --runstatedir=/run \
>>>                   --enable-tests \
>>>                   --enable-checks \
>>>                   --enable-asserts \
>>>
>> oops, ignore this please
>>
>> I didn't read the patch I put in fixes >.>
> 
> 
> There's also a problem with the way you send your patches. I used to
> have it too.
> 
> If I apply your patch through "git am", the author of the commit is:
> Sean Anderson via lists.openembedded.org
> <sean.anderson=seco.com@lists.openembedded.org>
> instead of
> Sean Anderson <sean.anderson@seco.com>
> 
> Because of this issue, the maintainer has to manually fix this field
> when accepting your patch. Worse, if he doesn't catch this, that's
> harder to fix afterwards.
> 
> You should be able to fix this by running:
> 
> git config --global sendemail.from "sean.anderson@seco.com"
> 
> At least this worked for me. See
> https://www.openembedded.org/wiki/How_to_submit_a_patch_to_OpenEmbedded#Sending_using_git-send-email
> 
> Don't hesitate to send a test e-mail to me first if you wish.

As remarked on before, this is because the mailing list is rewriting my
email address. It should be fixed to not do this. There are plenty of
mailing lists out there which do not have this issue and still work with
DMARC.

--Sean
diff mbox series

Patch

diff --git a/meta/recipes-core/dbus/dbus_1.14.0.bb b/meta/recipes-core/dbus/dbus_1.14.0.bb
index 0046b9fda2..9fb1f777bd 100644
--- a/meta/recipes-core/dbus/dbus_1.14.0.bb
+++ b/meta/recipes-core/dbus/dbus_1.14.0.bb
@@ -21,6 +21,7 @@  EXTRA_OECONF = "--disable-xml-docs \
                 --disable-doxygen-docs \
                 --enable-largefile \
                 --with-system-socket=/run/dbus/system_bus_socket \
+                --runstatedir=/run \
                 --enable-tests \
                 --enable-checks \
                 --enable-asserts \