diff mbox series

musl: Upgrade to latest master

Message ID 20221005235552.3380260-1-raj.khem@gmail.com
State Accepted, archived
Commit 1b0943925783f948fbb1f30ffd2f287c97f4f354
Headers show
Series musl: Upgrade to latest master | expand

Commit Message

Khem Raj Oct. 5, 2022, 11:55 p.m. UTC
Following changes are part of this SRCREV uprev

* dc9285ad fix error cases in gethostbyaddr_r
* f9827fc7 remove impossible error case from gethostbyname2_r
* f081d533 fix return value of gethostnbyname[2]_r on result not found
* 1e7fb12f dns: treat names rejected by res_mkquery as nonexistent rather than error
* 001c1afb res_mkquery: error out on consecutive final dots in name
* 3ad3fa96 fix thread leak on timer_create(SIGEV_THREAD) failure
* bf14ef19 re-enable vdso clock_gettime on arm (32-bit) with workaround
* 6f3ead0a process DT_RELR relocations in ldso-startup/static-pie
* 25085c85 fix fwprintf missing output to open_wmemstream FILEs
* a636fd63 dns: fail if ipv6 is disabled and resolv.conf has only v6 nameserves
* 996b6154 use kernel-provided AT_MINSIGSTKSZ for sysconf(_SC_[MIN]SIGSTKSZ)
* 25340a93 add sysconf keys/values for signal stack size
* d8fddb96 fix fallback when ipv6 is disabled but resolv.conf has v6 nameserves
* d4f987e4 epoll_create: fail with EINVAL if size is non-positive
* 2e5fff43 use alt signal stack when present for implementation-internal signals
* 379b1821 ldso: make exit condition clearer in fixup_rpath

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/musl/musl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 97c27eba4a..a72d87ea6f 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "37e18b7bf307fa4a8c745feebfcba54a0ba74f30"
+SRCREV = "dc9285ad1dc19349c407072cc48ba70dab86de45"
 
 BASEVER = "1.2.3"