diff mbox series

perf: Depend on setuptools

Message ID 20221005025625.64000-1-joel@jms.id.au
State New
Headers show
Series perf: Depend on setuptools | expand

Commit Message

Joel Stanley Oct. 5, 2022, 2:56 a.m. UTC
Linux 6.0 requires setuptools for building the perf Python bindings.

Signed-off-by: Joel Stanley <joel@jms.id.au>
---
 meta/recipes-kernel/perf/perf.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Bruce Ashfield Oct. 5, 2022, 3:04 a.m. UTC | #1
I sent this change a few hours ago, along with lttng fixes for 6.x.

Cheers,

Bruce

On Tue, Oct 4, 2022 at 10:56 PM Joel Stanley <joel@jms.id.au> wrote:
>
> Linux 6.0 requires setuptools for building the perf Python bindings.
>
> Signed-off-by: Joel Stanley <joel@jms.id.au>
> ---
>  meta/recipes-kernel/perf/perf.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
> index edb133515423..c87880b2c14c 100644
> --- a/meta/recipes-kernel/perf/perf.bb
> +++ b/meta/recipes-kernel/perf/perf.bb
> @@ -48,7 +48,7 @@ PROVIDES = "virtual/perf"
>  inherit linux-kernel-base kernel-arch manpages
>
>  # needed for building the tools/perf Python bindings
> -inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3native', '', d)}
> +inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3native setuptools3', '', d)}
>  inherit python3-dir
>  export PYTHON_SITEPACKAGES_DIR
>
> --
> 2.35.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#171437): https://lists.openembedded.org/g/openembedded-core/message/171437
> Mute This Topic: https://lists.openembedded.org/mt/94128875/1050810
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [bruce.ashfield@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index edb133515423..c87880b2c14c 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -48,7 +48,7 @@  PROVIDES = "virtual/perf"
 inherit linux-kernel-base kernel-arch manpages
 
 # needed for building the tools/perf Python bindings
-inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3native', '', d)}
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3native setuptools3', '', d)}
 inherit python3-dir
 export PYTHON_SITEPACKAGES_DIR