diff mbox series

hafnium: Exclude from world builds

Message ID 20220926222642.3105379-1-raj.khem@gmail.com
State New
Headers show
Series hafnium: Exclude from world builds | expand

Commit Message

Khem Raj Sept. 26, 2022, 10:26 p.m. UTC
This does not build with clang from meta-clang and also does not build
with gcc either

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Ross Burton Sept. 27, 2022, 10:11 a.m. UTC | #1
It brings its own compiler, so the host compiler shouldn’t be relevant.

What build configuration is making this break?  We can be more specific with exclusions than this.

Ross

> On 26 Sep 2022, at 23:26, Khem Raj via lists.yoctoproject.org <raj.khem=gmail.com@lists.yoctoproject.org> wrote:
> 
> This does not build with clang from meta-clang and also does not build
> with gcc either
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
> meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb | 2 ++
> 1 file changed, 2 insertions(+)
> 
> diff --git a/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb b/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
> index d90f747..0c4e294 100644
> --- a/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
> +++ b/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
> @@ -77,3 +77,5 @@ python() {
>     if d.getVar("BUILD_ARCH") != "x86_64":
>         raise bb.parse.SkipRecipe("Cannot be built on non-x86-64 hosts")
> }
> +
> +EXCLUDE_FROM_WORLD = "1"
> -- 
> 2.37.3
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#3842): https://lists.yoctoproject.org/g/meta-arm/message/3842
> Mute This Topic: https://lists.yoctoproject.org/mt/93938627/6875888
> Group Owner: meta-arm+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-arm/unsub [ross.burton@arm.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Sept. 27, 2022, 3:19 p.m. UTC | #2
On Tue, Sep 27, 2022 at 3:12 AM Ross Burton <Ross.Burton@arm.com> wrote:

> It brings its own compiler, so the host compiler shouldn’t be relevant.
>
> What build configuration is making this break?  We can be more specific
> with exclusions than this.


That’s fine it’s not building at all here so fixing that would be fine I
just wanted it to be either building or put aside

>
>
> Ross
>
> > On 26 Sep 2022, at 23:26, Khem Raj via lists.yoctoproject.org <raj.khem=
> gmail.com@lists.yoctoproject.org> wrote:
> >
> > This does not build with clang from meta-clang and also does not build
> > with gcc either
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> > meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb | 2 ++
> > 1 file changed, 2 insertions(+)
> >
> > diff --git a/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
> b/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
> > index d90f747..0c4e294 100644
> > --- a/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
> > +++ b/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
> > @@ -77,3 +77,5 @@ python() {
> >     if d.getVar("BUILD_ARCH") != "x86_64":
> >         raise bb.parse.SkipRecipe("Cannot be built on non-x86-64 hosts")
> > }
> > +
> > +EXCLUDE_FROM_WORLD = "1"
> > --
> > 2.37.3
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#3842):
> https://lists.yoctoproject.org/g/meta-arm/message/3842
> > Mute This Topic: https://lists.yoctoproject.org/mt/93938627/6875888
> > Group Owner: meta-arm+owner@lists.yoctoproject.org
> > Unsubscribe: https://lists.yoctoproject.org/g/meta-arm/unsub [
> ross.burton@arm.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
>
Jon Mason Sept. 28, 2022, 1:42 p.m. UTC | #3
On Mon, 26 Sep 2022 15:26:42 -0700, Khem Raj wrote:
> This does not build with clang from meta-clang and also does not build
> with gcc either

Applied, thanks!

[1/1] hafnium: Exclude from world builds
      commit: 4cd8d73788a9d98ad367f61447de28c719ca5ec3

Best regards,
Jon Mason Sept. 29, 2022, 6:56 p.m. UTC | #4
On Mon, 26 Sep 2022 15:26:42 -0700, Khem Raj wrote:
> This does not build with clang from meta-clang and also does not build
> with gcc either

Applied, thanks!

[1/1] hafnium: Exclude from world builds
      commit: 4cd8d73788a9d98ad367f61447de28c719ca5ec3

Best regards,
diff mbox series

Patch

diff --git a/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb b/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
index d90f747..0c4e294 100644
--- a/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
+++ b/meta-arm/recipes-bsp/hafnium/hafnium_2.7.bb
@@ -77,3 +77,5 @@  python() {
     if d.getVar("BUILD_ARCH") != "x86_64":
         raise bb.parse.SkipRecipe("Cannot be built on non-x86-64 hosts")
 }
+
+EXCLUDE_FROM_WORLD = "1"