diff mbox series

exiv2: Fix buildpaths warning.

Message ID 1663218472-5849-1-git-send-email-leimaohui@fujitsu.com
State Under Review
Headers show
Series exiv2: Fix buildpaths warning. | expand

Commit Message

Maohui Lei (Fujitsu) Sept. 15, 2022, 5:07 a.m. UTC
Remove the build path from file exiv2Config.cmake.

Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
---
 meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb b/meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb
index 31afe78e45..1380638ba7 100644
--- a/meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb
+++ b/meta-oe/recipes-support/exiv2/exiv2_0.27.3.bb
@@ -21,3 +21,10 @@  SRC_URI += "file://0001-Use-compiler-fcf-protection-only-if-compiler-arch-su.pat
 S = "${WORKDIR}/${BPN}-${PV}-Source"
 
 inherit cmake gettext
+
+do_install:append:class-target() {
+    # reproducibility: remove build host path
+    sed -i ${D}${libdir}/cmake/exiv2/exiv2Config.cmake \
+        -e 's:${STAGING_DIR_HOST}::g'
+}
+