diff mbox series

[v2] opkg: add option for zstd support

Message ID 20220914095945.2046769-1-ecordonnier@snap.com
State Accepted, archived
Commit a0892c3209e3892d79b97dcd4ec0e5a89057258c
Headers show
Series [v2] opkg: add option for zstd support | expand

Commit Message

Etienne Cordonnier Sept. 14, 2022, 9:59 a.m. UTC
This allows the use of zstd for opkg packages by using OPKGBUILDCMD:
OPKGBUILDCMD = "opkg-build -Z zstd"

Signed-off-by: Alex Feinman <afeinman@snap.com>
Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com>
---
 meta/recipes-devtools/opkg/opkg_0.6.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Alex Stewart Sept. 14, 2022, 3:29 p.m. UTC | #1
ACK from me.

On 9/14/22 04:59, Etienne Cordonnier via lists.openembedded.org wrote:
> This allows the use of zstd for opkg packages by using OPKGBUILDCMD:
> OPKGBUILDCMD = "opkg-build -Z zstd"
>
> Signed-off-by: Alex Feinman <afeinman@snap.com>
> Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com>
> ---
>   meta/recipes-devtools/opkg/opkg_0.6.0.bb | 1 +
>   1 file changed, 1 insertion(+)
>
> diff --git a/meta/recipes-devtools/opkg/opkg_0.6.0.bb b/meta/recipes-devtools/opkg/opkg_0.6.0.bb
> index 7b351e8123..4cd589cd29 100644
> --- a/meta/recipes-devtools/opkg/opkg_0.6.0.bb
> +++ b/meta/recipes-devtools/opkg/opkg_0.6.0.bb
> @@ -39,6 +39,7 @@ PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,\
>   PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
>   PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
>   PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
> +PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
>   PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
>   
>   EXTRA_OECONF:class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#170651): https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-core/message/170651__;!!FbZ0ZwI3Qg!s3ge2JNZe1G9vmQ-fsPaqWDO_Q31zeo7xvWaZyozqBUutvc_pqEPJh9YF4LJ284aTwx9LfkjOxEp2dzr_MM3cnXkAnz9-fO-i2Da$
> Mute This Topic: https://urldefense.com/v3/__https://lists.openembedded.org/mt/93674358/3616788__;!!FbZ0ZwI3Qg!s3ge2JNZe1G9vmQ-fsPaqWDO_Q31zeo7xvWaZyozqBUutvc_pqEPJh9YF4LJ284aTwx9LfkjOxEp2dzr_MM3cnXkAnz9-WZqAqb8$
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-core/unsub__;!!FbZ0ZwI3Qg!s3ge2JNZe1G9vmQ-fsPaqWDO_Q31zeo7xvWaZyozqBUutvc_pqEPJh9YF4LJ284aTwx9LfkjOxEp2dzr_MM3cnXkAnz9-a4JRFlg$   [alex.stewart@ni.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/opkg/opkg_0.6.0.bb b/meta/recipes-devtools/opkg/opkg_0.6.0.bb
index 7b351e8123..4cd589cd29 100644
--- a/meta/recipes-devtools/opkg/opkg_0.6.0.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.6.0.bb
@@ -39,6 +39,7 @@  PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,\
 PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
 PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
 PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
+PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
 PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
 
 EXTRA_OECONF:class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"