[meta-fsl-arm] gstreamer1.0-plugins-bad: remove patch

Submitted by Max Krummenacher on July 9, 2016, 9:19 a.m. | Patch ID: 126733

Details

Message ID 1468055970-3187-1-git-send-email-max.krummenacher@toradex.com
State New
Headers show

Commit Message

Max Krummenacher July 9, 2016, 9:19 a.m.
With the upgrade to gstremaer 1.8.x this patch does no longer apply.
Upstream changed to install the headers required, so the patch is also
no longer needed:
https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit?h=1.8&id=c87a7e266732ab9a0bd0e5a5c104b06d0f1a2072

Updated to 1.8 in oe-core:
http://cgit.openembedded.org/openembedded-core/commit/meta/recipes-multimedia/gstreamer?id=6a326f2b37b0b49e1144428becda32400498c024

or the poky git:
http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/meta/recipes-multimedia/gstreamer?id=79ca8d031e5a706f00d5c97ba23b496e6d700b7e

Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
---
 ...ll-gstaggregator-and-gstvideoaggregator-h.patch | 61 ----------------------
 .../gstreamer/gstreamer1.0-plugins-bad_%.bbappend  |  6 ---
 2 files changed, 67 deletions(-)
 delete mode 100755 recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch

Patch hide | download patch | download mbox

diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch
deleted file mode 100755
index 52e2d9a..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch
+++ /dev/null
@@ -1,61 +0,0 @@ 
-From 853d7f2ca821682c1e1e594b23ff654505e07054 Mon Sep 17 00:00:00 2001
-From: Mingke Wang <mingke.wang@freescale.com>
-Date: Wed, 1 Jul 2015 10:19:25 +0800
-Subject: [PATCH] [PATCH] install gstaggregator and gstvideoaggregator header
- file
-
-intall the header file of gstaggregator and gstvideoaggregator
-so that we can use them outside of gstreamer-plugins-bad package
-
-Upstream-Status: Inappropriate [i.MX specific]
-
-Signed-off-by: Mingke Wang <mingke.wang@freescale.com>
-
-diff --git a/gst-libs/gst/base/Makefile.am b/gst-libs/gst/base/Makefile.am
-old mode 100644
-new mode 100755
-index 0d55368..7268095
---- a/gst-libs/gst/base/Makefile.am
-+++ b/gst-libs/gst/base/Makefile.am
-@@ -6,11 +6,12 @@ libgstbadbase_@GST_API_VERSION@_la_SOURCES = \
- libgstbadbase_@GST_API_VERSION@_la_CFLAGS = $(GST_CFLAGS) \
- 	-DGST_USE_UNSTABLE_API
- 
-+libgstbadbase_@GST_API_VERSION@includedir = $(includedir)/gstreamer-@GST_API_VERSION@/gst/base
-+libgstbadbase_@GST_API_VERSION@include_HEADERS = \
-+        gstaggregator.h
-+
- libgstbadbase_@GST_API_VERSION@_la_LIBADD = $(GST_LIBS)
- libgstbadbase_@GST_API_VERSION@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS) $(GST_LT_LDFLAGS)
- 
--noinst_HEADERS =	\
--	gstaggregator.h
--
- EXTRA_DIST = 
- 
-diff --git a/gst-libs/gst/video/Makefile.am b/gst-libs/gst/video/Makefile.am
-old mode 100644
-new mode 100755
-index 4f0f09f..3c5da6b
---- a/gst-libs/gst/video/Makefile.am
-+++ b/gst-libs/gst/video/Makefile.am
-@@ -16,11 +16,14 @@ libgstbadvideo_@GST_API_VERSION@_la_CFLAGS = \
- 	$(GST_PLUGINS_BASE_CFLAGS) \
- 	$(GST_BASE_CFLAGS)
- 
-+libgstbadvideo_@GST_API_VERSION@includedir = $(includedir)/gstreamer-@GST_API_VERSION@/gst/video
-+libgstbadvideo_@GST_API_VERSION@include_HEADERS = \
-+        gstvideoaggregatorpad.h \
-+        gstvideoaggregator.h
-+
- libgstbadvideo_@GST_API_VERSION@_la_LIBADD = \
- 	$(top_builddir)/gst-libs/gst/base/libgstbadbase-$(GST_API_VERSION).la \
- 	$(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_API_VERSION) \
- 	$(GST_BASE_LIBS) $(GST_LIBS) $(ORC_LIBS) $(LIBM)
- 
- libgstbadvideo_@GST_API_VERSION@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS) $(GST_LT_LDFLAGS)
--
--noinst_HEADERS = gstvideoaggregatorpad.h gstvideoaggregator.h
--- 
-1.7.9.5
-
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index 11c4eb9..89aaafb 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -1,6 +1,5 @@ 
 # Vivante EGL headers require the correct preprocessor
 # defines to be set for each platform
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 CFLAGS_append_mx6 = " -DLINUX \
                       ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
@@ -10,11 +9,6 @@  PACKAGECONFIG_GL_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', \
                            bb.utils.contains('DISTRO_FEATURES', 'x11', \
                                     'opengl', '', d), '', d)}"
 
-SRC_URI_append_mx6 = " file://0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch"
-SRC_URI_append_mx6ul = " file://0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch"
-SRC_URI_append_mx7 = " file://0001-PATCH-install-gstaggregator-and-gstvideoaggregator-h.patch"
-
-
 PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}"
 PACKAGE_ARCH_mx6ul = "${MACHINE_SOCARCH}"
 PACKAGE_ARCH_mx7 = "${MACHINE_SOCARCH}"

Comments

Max Krummenacher July 9, 2016, 9:28 a.m.
Hi

Sorry, wrong list.
Please disregard.

Max