diff mbox series

[master/kirkstone,02/65] ti-tros-firmware: Add DM firmware binary to deploy directory for am62xx-evm

Message ID 20220913035541.2364351-3-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Latest 2022.09 sync-up with Dunfell #1 | expand

Commit Message

Denys Dmytriyenko Sept. 13, 2022, 3:54 a.m. UTC
From: Aparna M <a-m1@ti.com>

The DM firmware binary is required for building uboot binaries for
am62xx-evm  using toplevel makefile in SDK. Add this file to deploy
directory so it can be included in prebuilt-images directory of SDK
for am62xx-evm.

Signed-off-by: Aparna M <a-m1@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 .../recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb       | 12 ++++++++++++
 1 file changed, 12 insertions(+)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 93429570..317ff4c4 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -167,6 +167,16 @@  do_install:am62xx() {
     install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR}
 }
 
+
+do_deploy() {
+    install -d ${DEPLOYDIR}
+}
+
+do_deploy:am62xx() {
+    install -d ${DEPLOYDIR}
+    install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${DEPLOYDIR}
+}
+
 # Set up names for the firmwares
 ALTERNATIVE:${PN}:am65xx = "\
                     am65x-mcu-r5f0_0-fw \
@@ -355,3 +365,5 @@  INSANE_SKIP:${PN} += "arch"
 # we don't want to configure and build the source code
 do_compile[noexec] = "1"
 do_configure[noexec] = "1"
+
+addtask deploy after do_install