[meta-python] python3-gcovr: add recipe

Message ID 20211122101204.10405-1-ceggers@arri.de
State New
Headers show
Series [meta-python] python3-gcovr: add recipe | expand

Commit Message

Christian Eggers Nov. 22, 2021, 10:12 a.m. UTC
Self description from the website: Gcovr provides a utility for managing
the use of the GNU gcov utility and generating summarized code coverage
results. This command is inspired by the Python coverage.py package,
which provides a similar utility for Python.

Signed-off-by: Christian Eggers <ceggers@arri.de>
---
 .../recipes-devtools/python/python3-gcovr_5.0.bb | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-gcovr_5.0.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb b/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
new file mode 100644
index 000000000000..330831a0b3d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
@@ -0,0 +1,16 @@ 
+DESCRIPTION = "generate GCC code coverage reports"
+HOMEPAGE = "https://gcovr.com"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=08208c66520e8d69d5367483186d94ed"
+
+SRC_URI = "git://github.com/gcovr/gcovr.git;branch=master;protocol=https"
+SRCREV = "2b50284e8a6792b4ddcba14e2050c5c05f15deb6"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments"
+
+BBCLASSEXTEND = "native nativesdk"