diff mbox series

[PATCHv2] libsdl2: upgrade 2.0.22 -> 2.24.0

Message ID 20220905233841.5953-1-f_l_k@t-online.de
State New
Headers show
Series [PATCHv2] libsdl2: upgrade 2.0.22 -> 2.24.0 | expand

Commit Message

Markus Volk Sept. 5, 2022, 11:38 p.m. UTC
In addition to lots of bug fixes, here are the major changes in this release:

General:

New version numbering scheme, similar to GLib and Flatpak.
An even number in the minor version (second component) indicates a production-ready stable release such as 2.24.0, which would have been 2.0.24 under the old system.
The patchlevel (micro version, third component) indicates a bugfix-only update: for example, 2.24.1 would be a bugfix-only release to fix bugs in 2.24.0, without adding new features.
An odd number in the minor version indicates a prerelease such as 2.23.0. Stable distributions should not use these prereleases.
The patchlevel indicates successive prereleases, for example 2.23.1 and 2.23.2 would be prereleases during development of the SDL 2.24.0 stable release.
Added SDL_GetPointDisplayIndex() and SDL_GetRectDisplayIndex() to get the display associated with a point and rectangle in screen space
Added SDL_bsearch(), SDL_crc16(), and SDL_utf8strnlen() to the stdlib routines
Added SDL_CPUPauseInstruction() as a macro in SDL_atomic.h
Added SDL_size_mul_overflow() and SDL_size_add_overflow() for better size overflow protection
Added SDL_ResetHint() to reset a hint to the default value
Added SDL_ResetKeyboard() to reset SDL's internal keyboard state, generating key up events for all currently pressed keys
Added the hint SDL_HINT_MOUSE_RELATIVE_WARP_MOTION to control whether mouse warping generates motion events in relative mode. This hint defaults off.
Added the hint SDL_HINT_TRACKPAD_IS_TOUCH_ONLY to control whether trackpads are treated as touch devices or mice. By default touchpads are treated as mouse input.
The hint SDL_HINT_JOYSTICK_HIDAPI_JOY_CONS now defaults on
Added support for mini-gamepad mode for Nintendo Joy-Con controllers using the HIDAPI driver
Added the hint SDL_HINT_JOYSTICK_HIDAPI_COMBINE_JOY_CONS to control whether Joy-Con controllers are automatically merged into a unified gamepad when using the HIDAPI driver. This hint defaults on.
The hint SDL_HINT_JOYSTICK_HIDAPI_SWITCH_HOME_LED can be set to a floating point value to set the brightness of the Home LED on Nintendo Switch controllers
Added the hint SDL_HINT_JOYSTICK_HIDAPI_JOYCON_HOME_LED to set the Home LED brightness for the Nintendo Joy-Con controllers. By default the Home LED is not modified.
Added the hint SDL_HINT_JOYSTICK_HIDAPI_SWITCH_PLAYER_LED to control whether the player LED should be lit on the Nintendo Joy-Con controllers
Added support for Nintendo Online classic controllers using the HIDAPI driver
Added the hint SDL_HINT_JOYSTICK_HIDAPI_NINTENDO_CLASSIC to control whether the HIDAPI driver for Nintendo Online classic controllers should be used
Added support for the NVIDIA Shield Controller to the HIDAPI driver, supporting rumble and battery status
Added support for NVIDIA SHIELD controller to the HIDAPI driver, and a hint SDL_HINT_JOYSTICK_HIDAPI_SHIELD to control whether this is used
Added functions to get the platform dependent name for a joystick or game controller:
SDL_JoystickPathForIndex()
SDL_JoystickPath()
SDL_GameControllerPathForIndex()
SDL_GameControllerPath()
Added SDL_GameControllerGetFirmwareVersion() and SDL_JoystickGetFirmwareVersion(), currently implemented for DualSense(tm) Wireless Controllers using HIDAPI
Added SDL_JoystickAttachVirtualEx() for extended virtual controller support
Added joystick event SDL_JOYBATTERYUPDATED for when battery status changes
Added SDL_GUIDToString() and SDL_GUIDFromString() to convert between SDL GUID and string
Added SDL_HasLSX() and SDL_HasLASX() to detect LoongArch SIMD support
Added SDL_GetOriginalMemoryFunctions()
Added SDL_GetDefaultAudioInfo() to get the name and format of the default audio device, currently implemented for PipeWire, PulseAudio, WASAPI, and DirectSound
Added HIDAPI driver for the NVIDIA SHIELD controller (2017 model) to enable support for battery status and rumble
Added support for opening audio devices with 3 or 5 channels (2.1, 4.1). All channel counts from Mono to 7.1 are now supported.
Rewrote audio channel converters used by SDL_AudioCVT, based on the channel matrix coefficients used as the default for FAudio voices
SDL log messages are no longer limited to 4K and can be any length
Fixed a long-standing calling convention issue with dynapi affecting OpenWatcom or OS/2 builds
Windows:

Added initial support for building for Windows and Xbox with Microsoft's Game Development Kit (GDK), see docs/README-gdk.md for details
Added a D3D12 renderer implementation and SDL_RenderGetD3D12Device() to retrieve the D3D12 device associated with it
Added the hint SDL_HINT_WINDOWS_DPI_AWARENESS to set whether the application is DPI-aware. This hint must be set before initializing the video subsystem
Added the hint SDL_HINT_WINDOWS_DPI_SCALING to control whether the SDL coordinates are in DPI-scaled points or pixels
Added the hint SDL_HINT_DIRECTINPUT_ENABLED to control whether the DirectInput driver should be used
Added support for SDL_GetAudioDeviceSpec to the DirectSound backend
Linux:

Support for XVidMode has been removed, mode changes are only supported using the XRandR extension
Added the hint SDL_HINT_VIDEO_WAYLAND_MODE_EMULATION to control whether to expose a set of emulated modes in addition to the native resolution modes available on Wayland
Added the hint SDL_HINT_KMSDRM_DEVICE_INDEX to specify which KMSDRM device to use if the default is not desired
Added the hint SDL_HINT_LINUX_DIGITAL_HATS to control whether to treat hats as digital rather than checking to see if they may be analog
Added the hint SDL_HINT_LINUX_HAT_DEADZONES to control whether to use deadzones on analog hats
macOS:

Bumped minimum OS deployment version to macOS 10.9
Added SDL_GL_FLOATBUFFERS to allow Cocoa GL contexts to use EDR
Added the hint SDL_HINT_MAC_OPENGL_ASYNC_DISPATCH to control whether dispatching OpenGL context updates should block the dispatching thread until the main thread finishes processing. This hint defaults to blocking, which is the safer option on modern macOS.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../libsdl2/{libsdl2_2.0.22.bb => libsdl2_2.24.0.bb}         | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)
 rename meta/recipes-graphics/libsdl2/{libsdl2_2.0.22.bb => libsdl2_2.24.0.bb} (93%)
diff mbox series

Patch

diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.24.0.bb
similarity index 93%
rename from meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
rename to meta/recipes-graphics/libsdl2/libsdl2_2.24.0.bb
index 8519e7f732..8cdd08b179 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.24.0.bb
@@ -22,13 +22,12 @@  LIC_FILES_CHKSUM:append = " ${@bb.utils.contains('PACKAGECONFIG', 'arm-neon', 'f
 PROVIDES = "virtual/libsdl2"
 
 SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \
-           file://0001-video-restore-ability-to-disable-fb-accel-via-hint.patch \
            "
 SRC_URI:append:class-native = " file://0001-Disable-libunwind-in-native-OE-builds-by-not-looking.patch"
 
 S = "${WORKDIR}/SDL2-${PV}"
 
-SRC_URI[sha256sum] = "fe7cbf3127882e3fc7259a75a0cb585620272c51745d3852ab9dd87960697f2e"
+SRC_URI[sha256sum] = "91e4c34b1768f92d399b078e171448c6af18cafda743987ed2064a28954d6d97"
 
 inherit cmake lib_package binconfig-disabled pkgconfig
 
@@ -43,9 +42,7 @@  EXTRA_OECMAKE = "-DSDL_OSS=OFF -DSDL_ESD=OFF -DSDL_ARTS=OFF \
                  -DSDL_PTHREADS=ON \
                  -DSDL_RPATH=OFF \
                  -DSDL_SNDIO=OFF \
-                 -DSDL_X11_XVM=OFF \
                  -DSDL_X11_XCURSOR=OFF \
-                 -DSDL_X11_XINERAMA=OFF \
                  -DSDL_X11_XDBE=OFF \
                  -DSDL_X11_XFIXES=OFF \
                  -DSDL_X11_XINPUT=OFF \