diff mbox series

squashfs-tools: build with lzo support

Message ID 20220904052928.33120-1-f_l_k@t-online.de
State Accepted, archived
Commit dbe5d8334b7abe06c1d5808d37af0fb8d1d14037
Headers show
Series squashfs-tools: build with lzo support | expand

Commit Message

Markus Volk Sept. 4, 2022, 5:29 a.m. UTC
This is e.g. needed to be able to install snaps.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Sept. 4, 2022, 6:32 a.m. UTC | #1
On Sat, Sep 3, 2022 at 10:30 PM Markus Volk <f_l_k@t-online.de> wrote:
>
> This is e.g. needed to be able to install snaps.
>

I thought lzo was something we wanted to remove like lzop
so is it a hard dependency for snaps ?

> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
> index 0a7e0f2a52..4e009d2625 100644
> --- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
> +++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
> @@ -18,7 +18,7 @@ S = "${WORKDIR}/git"
>
>  EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}"
>
> -PACKAGECONFIG ??= "gzip xz lz4 lzma xattr zstd reproducible"
> +PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr zstd reproducible"
>  PACKAGECONFIG[gzip] = "GZIP_SUPPORT=1,GZIP_SUPPORT=0,zlib"
>  PACKAGECONFIG[xz] = "XZ_SUPPORT=1,XZ_SUPPORT=0,xz"
>  PACKAGECONFIG[lzo] = "LZO_SUPPORT=1,LZO_SUPPORT=0,lzo"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#170273): https://lists.openembedded.org/g/openembedded-core/message/170273
> Mute This Topic: https://lists.openembedded.org/mt/93453623/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Markus Volk Sept. 4, 2022, 1:44 p.m. UTC | #2
Am Sa, 3. Sep 2022 um 23:32:00 -0700 schrieb Khem Raj 
<raj.khem@gmail.com>:
> I thought lzo was something we wanted to remove like lzop
> so is it a hard dependency for snaps ?

It depends on how the snaps are constructed. Some time ago, the default 
compression in snap was changed from xz to lzo to decrease execution 
time at the expense of binary size. Since then 'snap install' breaks 
with the message that unsquashfs is missing lzo support.
I tested installing some snaps and all of them had this issue.  After I 
built squashfs-tools with lzo support, installing the snaps worked. 
Most of them did not run (probably because my test image is largely 
x11-free), but for example the firefox snap ran very well.
Markus Volk Sept. 4, 2022, 3:43 p.m. UTC | #3
<https://snapcraft.io/blog/why-lzo-was-chosen-as-the-new-compression-method>


>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
index 0a7e0f2a52..4e009d2625 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
@@ -18,7 +18,7 @@  S = "${WORKDIR}/git"
 
 EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}"
 
-PACKAGECONFIG ??= "gzip xz lz4 lzma xattr zstd reproducible"
+PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr zstd reproducible"
 PACKAGECONFIG[gzip] = "GZIP_SUPPORT=1,GZIP_SUPPORT=0,zlib"
 PACKAGECONFIG[xz] = "XZ_SUPPORT=1,XZ_SUPPORT=0,xz"
 PACKAGECONFIG[lzo] = "LZO_SUPPORT=1,LZO_SUPPORT=0,lzo"