diff mbox series

[meta-arago,dunfell,1/2] meta-arago: rename j7-evm to j721e-evm

Message ID 20220831175513.16160-1-afd@ti.com
State Rejected
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,dunfell,1/2] meta-arago: rename j7-evm to j721e-evm | expand

Commit Message

Andrew Davis Aug. 31, 2022, 5:55 p.m. UTC
In many places we use "j7" (the family name) when we should be using a
specific SoC or EVM and vice-versa. For instance when including
graphics drivers we add for all "j7" family, but what we really
want is only for some specific j7 SoC.

First step in untangling this is to make it clear that there is
no SoC called j7. There is a SoC called j721e with a j721e-evm.

Fix up this naming here.

Signed-off-by: Andrew Davis <afd@ti.com>
---
 meta-arago-distro/conf/distro/arago.conf                    | 2 +-
 meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb  | 4 ++--
 .../packagegroup-arago-tisdk-addons-sdk-host.bb             | 4 ++--
 .../packagegroups/packagegroup-arago-tisdk-addons.bb        | 4 ++--
 meta-arago-distro/recipes-core/packagegroups/ti-test.bb     | 4 ++--
 .../ti-tisdk-makefile/Makefile_sysfw-image                  | 6 +++---
 .../ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb              | 4 ++--
 .../gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend      | 4 ++--
 8 files changed, 16 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/meta-arago-distro/conf/distro/arago.conf b/meta-arago-distro/conf/distro/arago.conf
index 5fca73ba..c2f7c603 100644
--- a/meta-arago-distro/conf/distro/arago.conf
+++ b/meta-arago-distro/conf/distro/arago.conf
@@ -51,7 +51,7 @@  KERNEL_IMAGETYPES_am437x-hs-evm = "zImage fitImage"
 KERNEL_IMAGETYPES_am335x-hs-evm = "zImage fitImage"
 KERNEL_IMAGETYPES_am65xx-hs-evm = "Image fitImage"
 KERNEL_IMAGETYPES_am64xx-hs-evm = "Image fitImage"
-KERNEL_IMAGETYPES_j7-hs-evm = "Image fitImage"
+KERNEL_IMAGETYPES_j721e-hs-evm = "Image fitImage"
 KERNEL_IMAGETYPES_j7200-hs-evm = "Image fitImage"
 KERNEL_IMAGETYPES_j721s2-hs-evm = "Image fitImage"
 
diff --git a/meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb b/meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb
index 6df454fc..6b3745f4 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-core-bundle.bb
@@ -17,8 +17,8 @@  DEPLOY_SPL_NAME_k3 = "tispl.bin tiboot3.bin"
 
 DEPLOY_IMAGES_NAME_k3 = "bl31.bin bl32.bin"
 DEPLOY_IMAGES_NAME_append_am65xx = " sysfw.itb"
-DEPLOY_IMAGES_NAME_append_j7-evm = " sysfw.itb"
-DEPLOY_IMAGES_NAME_append_j7-hs-evm = " sysfw.itb"
+DEPLOY_IMAGES_NAME_append_j721e-evm = " sysfw.itb"
+DEPLOY_IMAGES_NAME_append_j721e-hs-evm = " sysfw.itb"
 DEPLOY_IMAGES_NAME_append_am65xx-evm = " sysfw-am65x-evm.itb sysfw-am65x_sr2-evm.itb"
 
 ARAGO_TISDK_IMAGE ?= "tisdk-core-bundle"
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons-sdk-host.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons-sdk-host.bb
index 062948d0..bd72b7d9 100644
--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons-sdk-host.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons-sdk-host.bb
@@ -41,11 +41,11 @@  UTILS_append_k3 = " \
     trusted-firmware-a-src \
 "
 
-UTILS_append_j7-evm = " \
+UTILS_append_j721e-evm = " \
     pru-icss-src \
 "
 
-UTILS_append_j7-hs-evm = " \
+UTILS_append_j721e-hs-evm = " \
     pru-icss-src \
 "
 
diff --git a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
index 094c47a2..8a56a235 100644
--- a/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/packagegroup-arago-tisdk-addons.bb
@@ -68,8 +68,8 @@  UTILS_append_am64xx = " ti-rtos-firmware pru-icss"
 UTILS_append_am62xx = " ti-rtos-firmware pru-icss"
 UTILS_append_am65xx = " ti-rtos-firmware pru-icss pru-pwm-fw"
 UTILS_append_j7 = " ti-rtos-firmware"
-UTILS_append_j7-evm = " pru-icss"
-UTILS_append_j7-hs-evm = " pru-icss"
+UTILS_append_j721e-evm = " pru-icss"
+UTILS_append_j721e-hs-evm = " pru-icss"
 
 UTILS_append_omapl138 = " ti-ipc-rtos-fw"
 
diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
index 5c33f5aa..42de2614 100644
--- a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
@@ -84,12 +84,12 @@  ARAGO_TI_TEST_append_j7 = " \
     ufs-utils \
 "
 
-ARAGO_TI_TEST_append_j7-evm = " \
+ARAGO_TI_TEST_append_j721e-evm = " \
     viddec-test-app \
     videnc-test-app \
 "
 
-ARAGO_TI_TEST_append_j7-hs-evm = " \
+ARAGO_TI_TEST_append_j721e-hs-evm = " \
     viddec-test-app \
     videnc-test-app \
 "
diff --git a/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile/Makefile_sysfw-image b/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile/Makefile_sysfw-image
index 08d80c35..cbb20c51 100644
--- a/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile/Makefile_sysfw-image
+++ b/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile/Makefile_sysfw-image
@@ -2,7 +2,7 @@ 
 PLATFORM_TYPE_$(PLATFORM) = gp
 PLATFORM_TYPE_am64xx-hs-evm = hs
 PLATFORM_TYPE_am65xx-hs-evm = hs
-PLATFORM_TYPE_j7-hs-evm = hs
+PLATFORM_TYPE_j721e-hs-evm = hs
 PLATFORM_TYPE = $(PLATFORM_TYPE_$(PLATFORM))
 
 SYSFW_CONFIG = evm
@@ -13,8 +13,8 @@  SYSFW_SOC_am65xx-hs-evm = am65x
 SYSFW_SOC_am64xx-evm = am64x
 SYSFW_SOC_am64xx-hs-evm = am64x
 SYSFW_SOC_am62xx-evm = am62x
-SYSFW_SOC_j7-evm = j721e
-SYSFW_SOC_j7-hs-evm = j721e
+SYSFW_SOC_j721e-evm = j721e
+SYSFW_SOC_j721e-hs-evm = j721e
 SYSFW_SOC = $(SYSFW_SOC_$(PLATFORM))
 
 SYSFW_PREFIX_$(SYSFW_SOC) = ti-sci-firmware
diff --git a/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb b/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb
index 471e2776..5794e67e 100644
--- a/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb
+++ b/meta-arago-distro/recipes-tisdk/ti-tisdk-makefile/ti-tisdk-makefile_1.0.bb
@@ -370,8 +370,8 @@  K3_UBOOT_MACHINE_R5_am65xx-evm = "am65x_evm_r5_defconfig"
 K3_UBOOT_MACHINE_R5_am65xx-hs-evm = "am65x_hs_evm_r5_defconfig"
 K3_UBOOT_MACHINE_R5_am64xx-evm = "am64x_evm_r5_defconfig"
 K3_UBOOT_MACHINE_R5_am64xx-hs-evm = "am64x_hs_evm_r5_defconfig"
-K3_UBOOT_MACHINE_R5_j7-evm = "j721e_evm_r5_config"
-K3_UBOOT_MACHINE_R5_j7-hs-evm = "j721e_hs_evm_r5_config"
+K3_UBOOT_MACHINE_R5_j721e-evm = "j721e_evm_r5_config"
+K3_UBOOT_MACHINE_R5_j721e-hs-evm = "j721e_hs_evm_r5_config"
 K3_UBOOT_MACHINE_R5_j7200-evm = "j7200_evm_r5_config"
 K3_UBOOT_MACHINE_R5_j721s2-evm = "j721s2_evm_r5_config"
 K3_UBOOT_MACHINE_R5_am62xx-evm = "am62x_evm_r5_config"
diff --git a/meta-arago-extras/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend b/meta-arago-extras/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
index 64929729..258bf733 100644
--- a/meta-arago-extras/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
+++ b/meta-arago-extras/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
@@ -28,11 +28,11 @@  SRC_URI_append_am65xx = " \
     ${GSTDRM_WAYLANDSINK_PATCHES} \
 "
 
-SRC_URI_append_j7-evm = " \
+SRC_URI_append_j721e-evm = " \
     ${GSTDRM_WAYLANDSINK_PATCHES} \
 "
 
-SRC_URI_append_j7-hs-evm = " \
+SRC_URI_append_j721e-hs-evm = " \
     ${GSTDRM_WAYLANDSINK_PATCHES} \
 "