diff mbox series

[meta-ti,dunfell,3/3] meta-ti: Use new J7 SoC names over specific board names

Message ID 20220831175315.15942-4-afd@ti.com
State Rejected
Delegated to: Ryan Eatmon
Headers show
Series J7 name backports from master/kirkstone | expand

Commit Message

Andrew Davis Aug. 31, 2022, 5:53 p.m. UTC
Now that we have SoC names, we can avoid adding features based on the
board name. We expect folks to create their own boards based on these
SoCs, and so using the TI made EVM board name everywhere adds extra churn
when adding a new board. Plus it is more correct for most of these
features as they depend on the SoC, not on the EVM board.

Signed-off-by: Andrew Davis <afd@ti.com>
---
 recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb |  2 +-
 .../ti-img-rogue-driver_1.15.6133109.bb            | 14 +++++---------
 .../ti-img-encode-decode/viddec-test-app_1.0.0.bb  |  2 +-
 .../ti-img-encode-decode/videnc-test-app_1.0.0.bb  |  2 +-
 .../libgles/ti-img-rogue-umlibs_1.15.6133109.bb    |  8 +++-----
 recipes-kernel/linux/kernel-rdepends.inc           |  6 ++----
 6 files changed, 13 insertions(+), 21 deletions(-)
diff mbox series

Patch

diff --git a/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb b/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
index 0967e674..5528bfbc 100644
--- a/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
+++ b/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
@@ -10,7 +10,7 @@  PR = "${INC_PR}.0"
 
 CLEANBROKEN = "1"
 
-COMPATIBLE_MACHINE = "j721e-evm|j721e-hs-evm"
+COMPATIBLE_MACHINE = "j721e"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
index bdb48b85..2b6916fb 100644
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
@@ -11,7 +11,7 @@  MACHINE_KERNEL_PR_append = "b"
 PR = "${MACHINE_KERNEL_PR}"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "j721e-evm|j721e-hs-evm|j721s2-evm|j721s2-hs-evm|am62xx"
+COMPATIBLE_MACHINE = "j721e|j721s2|am62xx"
 
 DEPENDS = "virtual/kernel"
 
@@ -28,15 +28,11 @@  S = "${WORKDIR}/git"
 
 SRCREV = "6d3d62a15ceb85b719c35f34c6c9e35f556b406b"
 
-TARGET_PRODUCT_j721e-evm = "j721e_linux"
-TARGET_PRODUCT_j721e-hs-evm = "j721e_linux"
-TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
-TARGET_PRODUCT_j721s2-hs-evm = "j721s2_linux"
+TARGET_PRODUCT_j721e = "j721e_linux"
+TARGET_PRODUCT_j721s2 = "j721s2_linux"
 TARGET_PRODUCT_am62xx = "am62_linux"
-TARGET_BVNC_j721e-evm = "22.104.208.318"
-TARGET_BVNC_j721e-hs-evm = "22.104.208.318"
-TARGET_BVNC_j721s2-evm = "36.53.104.796"
-TARGET_BVNC_j721s2-hs-evm = "36.53.104.796"
+TARGET_BVNC_j721e = "22.104.208.318"
+TARGET_BVNC_j721s2 = "36.53.104.796"
 TARGET_BVNC_am62xx = "33.15.11.3"
 PVR_BUILD = "release"
 PVR_WS = "wayland"
diff --git a/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb b/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb
index 4add7e33..599bd44b 100644
--- a/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb
+++ b/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb
@@ -6,7 +6,7 @@  DEPENDS = "libdrm ffmpeg"
 
 inherit autotools pkgconfig
 
-COMPATIBLE_MACHINE = "j721e-evm|j721e-hs-evm"
+COMPATIBLE_MACHINE = "j721e"
 
 PR = "r1"
 SRCREV = "94a80c8c090dbfdc7fafd4e5bb78c2091e715af2"
diff --git a/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb b/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb
index a57acf64..54bf594d 100644
--- a/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb
+++ b/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb
@@ -6,7 +6,7 @@  DEPENDS = "libdrm"
 
 inherit autotools pkgconfig
 
-COMPATIBLE_MACHINE = "j721e-evm|j721e-hs-evm"
+COMPATIBLE_MACHINE = "j721e"
 
 PR = "r0"
 SRCREV = "a5e7d820bea1be24f25a8369d4d4521c784f869a"
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
index 5c6484a5..a5609ac5 100644
--- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
+++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
@@ -8,7 +8,7 @@  inherit features_check
 REQUIRED_MACHINE_FEATURES = "gpu"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "j721e-evm|j721e-hs-evm|j721s2-evm|j721s2-hs-evm|am62xx"
+COMPATIBLE_MACHINE = "j721e|j721s2|am62xx"
 
 PR = "r2"
 
@@ -17,10 +17,8 @@  BRANCH = "linuxws/dunfell/k5.10/${PV}_unified_fw_pagesize"
 SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}"
 SRCREV = "fba0c770b712640ab3761dbe8369d43f89f616ed"
 
-TARGET_PRODUCT_j721e-evm = "j721e_linux"
-TARGET_PRODUCT_j721e-hs-evm = "j721e_linux"
-TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
-TARGET_PRODUCT_j721s2-hs-evm = "j721s2_linux"
+TARGET_PRODUCT_j721e = "j721e_linux"
+TARGET_PRODUCT_j721s2 = "j721s2_linux"
 TARGET_PRODUCT_am62xx = "am62_linux"
 PVR_BUILD ?= "release"
 PVR_WS = "wayland"
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
index c6bae54b..047c4ec7 100644
--- a/recipes-kernel/linux/kernel-rdepends.inc
+++ b/recipes-kernel/linux/kernel-rdepends.inc
@@ -38,15 +38,13 @@  RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2 p
 RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am64xx = " prueth-fw-am65x-sr2"
 
 # Add run-time dependency for Cadence MHDP firmware to the rootfs
-RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721e-evm = " cadence-mhdp-fw"
-RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721e-hs-evm = " cadence-mhdp-fw"
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721e = " cadence-mhdp-fw"
 
 # Add run-time dependency for Video Decoding firmware to the rootfs
 RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " vxd-dec-fw"
 
 # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
-RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-evm = " cnm-wave-fw"
-RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-hs-evm = " cnm-wave-fw"
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2 = " cnm-wave-fw"
 
 # Add run-time dependency for TIFS Low Power Module stub
 RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am62xx-evm = " tifs-lpm-stub"