diff mbox series

ncurses: Fix configure tests for exit and mbstate_t

Message ID 20220830225832.2700943-1-raj.khem@gmail.com
State Accepted, archived
Commit 92f191c304b5d53c14be23f7a5d57b0f9f101767
Headers show
Series ncurses: Fix configure tests for exit and mbstate_t | expand

Commit Message

Khem Raj Aug. 30, 2022, 10:58 p.m. UTC
These tests do not include needed headers which results in warnings and
as errors when using -Werror or latest clang e.g.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../ncurses/files/exit_prototype.patch        | 22 +++++++++++++++++++
 .../ncurses/ncurses_6.3+20220423.bb           |  1 +
 2 files changed, 23 insertions(+)
 create mode 100644 meta/recipes-core/ncurses/files/exit_prototype.patch

Comments

Alexander Kanavin Aug. 31, 2022, 6:08 a.m. UTC | #1
On Wed, 31 Aug 2022 at 00:58, Khem Raj <raj.khem@gmail.com> wrote:
> +Add needed headers for including mbstate_t and exit()
> +
> +Upstream-Status: Inappropriate [Reconfigure will solve it]
> +Signed-off-by: Khem Raj <raj.khem@gmail.com>

This would benefit from a better explanation: why isn't configure.ac
being patched? What is 'reconfigure' and how it will solve the
problem, and when will it happen?

Alex
Khem Raj Aug. 31, 2022, 7:35 a.m. UTC | #2
On Tue, Aug 30, 2022 at 11:08 PM Alexander Kanavin
<alex.kanavin@gmail.com> wrote:
>
> On Wed, 31 Aug 2022 at 00:58, Khem Raj <raj.khem@gmail.com> wrote:
> > +Add needed headers for including mbstate_t and exit()
> > +
> > +Upstream-Status: Inappropriate [Reconfigure will solve it]
> > +Signed-off-by: Khem Raj <raj.khem@gmail.com>
>
> This would benefit from a better explanation: why isn't configure.ac
> being patched? What is 'reconfigure' and how it will solve the
> problem, and when will it happen?

its obvious in recipe, do_configure does not regenerate configure
script like most of autotools recipes do.
autoreconf will use new macros when regenerating the configure script.

>
> Alex
diff mbox series

Patch

diff --git a/meta/recipes-core/ncurses/files/exit_prototype.patch b/meta/recipes-core/ncurses/files/exit_prototype.patch
new file mode 100644
index 0000000000..791421a338
--- /dev/null
+++ b/meta/recipes-core/ncurses/files/exit_prototype.patch
@@ -0,0 +1,22 @@ 
+Add needed headers for including mbstate_t and exit()
+
+Upstream-Status: Inappropriate [Reconfigure will solve it]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/configure
++++ b/configure
+@@ -3422,6 +3422,7 @@ rm -f "conftest.$ac_objext" "conftest.$a
+   cat >"conftest.$ac_ext" <<_ACEOF
+ #line 3423 "configure"
+ #include "confdefs.h"
++#include <stdlib.h>
+ $ac_declaration
+ int
+ main (void)
+@@ -12997,6 +12998,7 @@ cat >"conftest.$ac_ext" <<_ACEOF
+ #include <stdlib.h>
+ #include <stdarg.h>
+ #include <stdio.h>
++#include <wchar.h>
+ #ifdef HAVE_LIBUTF8_H
+ #include <libutf8.h>
+ #endif
diff --git a/meta/recipes-core/ncurses/ncurses_6.3+20220423.bb b/meta/recipes-core/ncurses/ncurses_6.3+20220423.bb
index 9fba5b584b..ca5fa32572 100644
--- a/meta/recipes-core/ncurses/ncurses_6.3+20220423.bb
+++ b/meta/recipes-core/ncurses/ncurses_6.3+20220423.bb
@@ -3,6 +3,7 @@  require ncurses.inc
 SRC_URI += "file://0001-tic-hang.patch \
            file://0002-configure-reproducible.patch \
            file://0003-gen-pkgconfig.in-Do-not-include-LDFLAGS-in-generated.patch \
+           file://exit_prototype.patch \
            "
 # commit id corresponds to the revision in package version
 SRCREV = "20db1fb41ec91cd8a1f528e770362092c5403378"