[meta-python,3/3] python3-jedi: Upgrade 0.18.0 -> 0.18.1

Message ID 20211118123727.45056-3-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/3] python3-deprecated: Upgrade 1.2.12 -> 1.2.13 | expand

Commit Message

Leon Anavi Nov. 18, 2021, 12:37 p.m. UTC
Upgrade to release 0.18.1:

- Implict namespaces are now a separate types in Name().type
- Python 3.10 support
- Mostly bugfixes

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...{python3-jedi_0.18.0.bb => python3-jedi_0.18.1.bb} | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-jedi_0.18.0.bb => python3-jedi_0.18.1.bb} (56%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-jedi_0.18.0.bb b/meta-python/recipes-devtools/python/python3-jedi_0.18.1.bb
similarity index 56%
rename from meta-python/recipes-devtools/python/python3-jedi_0.18.0.bb
rename to meta-python/recipes-devtools/python/python3-jedi_0.18.1.bb
index 0ea5b46b8..fb582c54b 100644
--- a/meta-python/recipes-devtools/python/python3-jedi_0.18.0.bb
+++ b/meta-python/recipes-devtools/python/python3-jedi_0.18.1.bb
@@ -6,8 +6,15 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5ed06eebfcb244cd66ebf6cef9c23ab4"
 
 PYPI_PACKAGE = "jedi"
 
-SRC_URI[sha256sum] = "92550a404bad8afed881a137ec9a461fed49eca661414be45059329614ed0707"
+SRC_URI[sha256sum] = "74137626a64a99c8eb6ae5832d99b3bdd7d29a3850fe2aa80a4126b2a7d949ab"
 
-RDEPENDS:${PN} = "${PYTHON_PN}-parso"
+RDEPENDS:${PN} = " \
+	${PYTHON_PN}-parso \
+	${PYTHON_PN}-core \
+	${PYTHON_PN}-compression \
+	${PYTHON_PN}-pydoc \
+	${PYTHON_PN}-compile \
+	${PYTHON_PN}-json \
+"
 
 inherit setuptools3 pypi