[meta-python,4/5] python3-aiosignal: Add recipe

Message ID 20211115185652.27542-4-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/5] python3-cchardet: Add recipe | expand

Commit Message

Leon Anavi Nov. 15, 2021, 6:56 p.m. UTC
A list of registered asynchronous callbacks. Version 1.2.0:

- Added support for Python 3.10
- Mark aiosignal as Python3-only package

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-aiosignal_1.2.0.bb                | 12 ++++++++++++
 1 file changed, 12 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb b/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb
new file mode 100644
index 000000000..601ac8f45
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiosignal_1.2.0.bb
@@ -0,0 +1,12 @@ 
+SUMMARY = "A list of registered asynchronous callbacks"
+HOMEPAGE = "https://github.com/aio-libs/aiosignal"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cf056e8e7a0a5477451af18b7b5aa98c"
+
+SRC_URI[sha256sum] = "78ed67db6c7b7ced4f98e495e572106d5c432a93e1ddd1bf475e1dc05f5b7df2"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+	${PYTHON_PN}-frozenlist \
+"