diff mbox series

[meta-java,1/3] classpath: Use an include file for x11 feature check

Message ID 20220817114308.347965-1-andrei@gherzan.com
State New
Headers show
Series [meta-java,1/3] classpath: Use an include file for x11 feature check | expand

Commit Message

Andrei Gherzan Aug. 17, 2022, 11:43 a.m. UTC
From: Andrei Gherzan <andrei.gherzan@huawei.com>

This will make it easier to maintain reflecting the same distro check on
packages depending on classpath (in the dependency chain).

Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com>
---
 recipes-core/classpath/classpath-features-check.inc | 6 ++++++
 recipes-core/classpath/classpath_0.99.bb            | 4 +---
 2 files changed, 7 insertions(+), 3 deletions(-)
 create mode 100644 recipes-core/classpath/classpath-features-check.inc

Comments

Richard Leitner Aug. 22, 2022, 7:38 a.m. UTC | #1
On Wed, Aug 17, 2022 at 01:43:06PM +0200, Andrei Gherzan via lists.openembedded.org wrote:
> From: Andrei Gherzan <andrei.gherzan@huawei.com>

Hi Andrei,

thanks for the series. I've just applied them to master-next. As soon as
some testing happened I will merge them to master.

If you have any question please just drop me a line.

regards;rl

> 
> This will make it easier to maintain reflecting the same distro check on
> packages depending on classpath (in the dependency chain).
> 
> Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com>
> ---
>  recipes-core/classpath/classpath-features-check.inc | 6 ++++++
>  recipes-core/classpath/classpath_0.99.bb            | 4 +---
>  2 files changed, 7 insertions(+), 3 deletions(-)
>  create mode 100644 recipes-core/classpath/classpath-features-check.inc
> 
> diff --git a/recipes-core/classpath/classpath-features-check.inc b/recipes-core/classpath/classpath-features-check.inc
> new file mode 100644
> index 0000000..c238fc3
> --- /dev/null
> +++ b/recipes-core/classpath/classpath-features-check.inc
> @@ -0,0 +1,6 @@
> +# SPDX-FileCopyrightText: Huawei Inc.
> +#
> +# SPDX-License-Identifier: Apache-2.0
> +
> +inherit features_check
> +REQUIRED_DISTRO_FEATURES = "x11"
> diff --git a/recipes-core/classpath/classpath_0.99.bb b/recipes-core/classpath/classpath_0.99.bb
> index 5b9d904..f18ad1d 100644
> --- a/recipes-core/classpath/classpath_0.99.bb
> +++ b/recipes-core/classpath/classpath_0.99.bb
> @@ -1,8 +1,6 @@
>  require classpath.inc
>  
> -inherit features_check
> -
> -REQUIRED_DISTRO_FEATURES = "x11"
> +include classpath-features-check.inc
>  
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=92acc79f1f429143f4624d07b253702a"
>  
> -- 
> 2.25.1
>
Andrei Gherzan Aug. 22, 2022, 7:46 a.m. UTC | #2
On Mon, 22 Aug 2022, at 08:38, Richard Leitner wrote:
> On Wed, Aug 17, 2022 at 01:43:06PM +0200, Andrei Gherzan via 
> lists.openembedded.org wrote:
>> From: Andrei Gherzan <andrei.gherzan@huawei.com>
>
> Hi Andrei,
>
> thanks for the series. I've just applied them to master-next. As soon as
> some testing happened I will merge them to master.
>
> If you have any question please just drop me a line.

Thanks, Richard. I've also sent the series against kirkstone. It'd be awesome if we could do the same there. Is the testing something automated that I can check out logs on?

Andrei
Richard Leitner Aug. 22, 2022, 8:15 a.m. UTC | #3
On Mon, Aug 22, 2022 at 08:46:45AM +0100, Andrei Gherzan via lists.openembedded.org wrote:
> On Mon, 22 Aug 2022, at 08:38, Richard Leitner wrote:
> > On Wed, Aug 17, 2022 at 01:43:06PM +0200, Andrei Gherzan via 
> > lists.openembedded.org wrote:
> >> From: Andrei Gherzan <andrei.gherzan@huawei.com>
> >
> > Hi Andrei,
> >
> > thanks for the series. I've just applied them to master-next. As soon as
> > some testing happened I will merge them to master.
> >
> > If you have any question please just drop me a line.
> 
> Thanks, Richard. I've also sent the series against kirkstone. It'd be awesome if we could do the same there. Is the testing something automated that I can check out logs on?

As currently master and kirkstone are the same I will simply merge
kirkstone with master as soon as the changes were merged to master if
that's OK with you?

Unfortunately the testing infrastructure is not public available :(

But ideas/offers where to host a public test runner are highly
appreciated ;-)

regards;rl

> 
> Andrei
Andrei Gherzan Aug. 22, 2022, 9:28 a.m. UTC | #4
On Mon, 22 Aug 2022, at 09:15, Richard Leitner wrote:
> On Mon, Aug 22, 2022 at 08:46:45AM +0100, Andrei Gherzan via 
> lists.openembedded.org wrote:
>> On Mon, 22 Aug 2022, at 08:38, Richard Leitner wrote:
>> > On Wed, Aug 17, 2022 at 01:43:06PM +0200, Andrei Gherzan via 
>> > lists.openembedded.org wrote:
>> >> From: Andrei Gherzan <andrei.gherzan@huawei.com>
>> >
>> > Hi Andrei,
>> >
>> > thanks for the series. I've just applied them to master-next. As soon as
>> > some testing happened I will merge them to master.
>> >
>> > If you have any question please just drop me a line.
>> 
>> Thanks, Richard. I've also sent the series against kirkstone. It'd be awesome if we could do the same there. Is the testing something automated that I can check out logs on?
>
> As currently master and kirkstone are the same I will simply merge
> kirkstone with master as soon as the changes were merged to master if
> that's OK with you?

Sounds good.

>
> Unfortunately the testing infrastructure is not public available :(

Got it. That's fine. I'll just keep an eye on the repo.

>
> But ideas/offers where to host a public test runner are highly
> appreciated ;-)

What is the current testing plan for the layer?

Andrei
Richard Leitner Aug. 23, 2022, 4:31 a.m. UTC | #5
On Mon, Aug 22, 2022 at 10:28:34AM +0100, Andrei Gherzan wrote:
> On Mon, 22 Aug 2022, at 09:15, Richard Leitner wrote:
> >
> > Unfortunately the testing infrastructure is not public available :(
> 
> Got it. That's fine. I'll just keep an eye on the repo.
> 
> >
> > But ideas/offers where to host a public test runner are highly
> > appreciated ;-)
> 
> What is the current testing plan for the layer?

It's basically running the image tests for arm, armv7, arm64, x86,
x86_64 and ppc with the mejate and mejate-musl distribution.

I can prepare and share a repository containing those kas and gitlab-ci
configurations if that's interesting to you?

regards;rl

> Andrei
Andrei Gherzan Aug. 24, 2022, 4:29 p.m. UTC | #6
On Tue, 23 Aug 2022, at 05:31, Richard Leitner wrote:
> On Mon, Aug 22, 2022 at 10:28:34AM +0100, Andrei Gherzan wrote:
>> On Mon, 22 Aug 2022, at 09:15, Richard Leitner wrote:
>> >
>> > Unfortunately the testing infrastructure is not public available :(
>> 
>> Got it. That's fine. I'll just keep an eye on the repo.
>> 
>> >
>> > But ideas/offers where to host a public test runner are highly
>> > appreciated ;-)
>> 
>> What is the current testing plan for the layer?
>
> It's basically running the image tests for arm, armv7, arm64, x86,
> x86_64 and ppc with the mejate and mejate-musl distribution.
>
> I can prepare and share a repository containing those kas and gitlab-ci
> configurations if that's interesting to you?

Sure. Send them over when you get a chance.

BTW, did the testing finish? Are we able to push the changes?

Andrei
Andrei Gherzan Aug. 30, 2022, 9:31 a.m. UTC | #7
On Wed, 24 Aug 2022, at 17:29, Andrei Gherzan wrote:
> On Tue, 23 Aug 2022, at 05:31, Richard Leitner wrote:
>> On Mon, Aug 22, 2022 at 10:28:34AM +0100, Andrei Gherzan wrote:
>>> On Mon, 22 Aug 2022, at 09:15, Richard Leitner wrote:
>>> >
>>> > Unfortunately the testing infrastructure is not public available :(
>>> 
>>> Got it. That's fine. I'll just keep an eye on the repo.
>>> 
>>> >
>>> > But ideas/offers where to host a public test runner are highly
>>> > appreciated ;-)
>>> 
>>> What is the current testing plan for the layer?
>>
>> It's basically running the image tests for arm, armv7, arm64, x86,
>> x86_64 and ppc with the mejate and mejate-musl distribution.
>>
>> I can prepare and share a repository containing those kas and gitlab-ci
>> configurations if that's interesting to you?
>
> Sure. Send them over when you get a chance.
>
> BTW, did the testing finish? Are we able to push the changes?

Hi Richard,

Do we have any updates on this patch set? It would be great if we could get it in kirkstone soon.

Thanks,
Andrei
Richard Leitner Aug. 30, 2022, 3:10 p.m. UTC | #8
On Tue, Aug 30, 2022 at 10:31:04AM +0100, Andrei Gherzan wrote:

...

> Do we have any updates on this patch set? It would be great if we could get it in kirkstone soon.

I'm currently facing problems with some of the tests/builds for arm64. I
hope to get them sorted out today or tomorrow.

I'll give you a ping as soon as those tests are finished successfully.

regards;rl

> 
> Thanks,
> Andrei
Andrei Gherzan Aug. 30, 2022, 4:04 p.m. UTC | #9
On Tue, 30 Aug 2022, at 16:10, Richard Leitner wrote:
> On Tue, Aug 30, 2022 at 10:31:04AM +0100, Andrei Gherzan wrote:
>
> ...
>
>> Do we have any updates on this patch set? It would be great if we could get it in kirkstone soon.
>
> I'm currently facing problems with some of the tests/builds for arm64. I
> hope to get them sorted out today or tomorrow.
>
> I'll give you a ping as soon as those tests are finished successfully.

Thanks for the update. One small thing that I have realised - the patches I've pushed have the SPDX headers with an Apache license. Could you change that to MIT? I can also send a v2 series if that is easier for you.

Andrei
diff mbox series

Patch

diff --git a/recipes-core/classpath/classpath-features-check.inc b/recipes-core/classpath/classpath-features-check.inc
new file mode 100644
index 0000000..c238fc3
--- /dev/null
+++ b/recipes-core/classpath/classpath-features-check.inc
@@ -0,0 +1,6 @@ 
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+inherit features_check
+REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/recipes-core/classpath/classpath_0.99.bb b/recipes-core/classpath/classpath_0.99.bb
index 5b9d904..f18ad1d 100644
--- a/recipes-core/classpath/classpath_0.99.bb
+++ b/recipes-core/classpath/classpath_0.99.bb
@@ -1,8 +1,6 @@ 
 require classpath.inc
 
-inherit features_check
-
-REQUIRED_DISTRO_FEATURES = "x11"
+include classpath-features-check.inc
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=92acc79f1f429143f4624d07b253702a"